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Lekcija 01 

Maya - Uvod 
 

Povzetek 

1. Uporabniški vmesnik 

2. Projekti in datoteke 

3. Pogledi v sceno 

4. Predmeti in komponente (angl. objects and components) 

5. Primitvna telesa 

6. Osnovne transformacije in prijemališča 

Sestava uporabniškega vmesnika 

 

Privzeti zaslon je sestavljen iz (glej sliko zgoraj):  

● Menijska vrstica (svetlo rdeča) vsebuje menije preko katerih dostopamo do orodij in/ali 

izvajamo želene akcije pri modeliranju, upodabljanju, animaciji, ... Prvih 6 menijev se ne 

spreminja, ostali pa so odvisni od izbranega načina dela, ki ga izberemo v statusni vrstici; 

Glavna menijska vrstica

Statusna vrstica

Polica (shelf )

Orodjarna

Delovni prostor

Menijska vrstica

in orodjarna pogleda

Okno kanalov

Urejevalnik plast i

Vrstica pomoči

Časovni trak

Ukazna vrstica
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● Statusna vrstica (svetlo zelena), vsebuje množico bljižnic do ukazov ter orodja za način 

izbire predmetov in komponent. Poleg tega lahko v statusni vrstici izberemo način dela in 

tako prilagodimo sestavo menijev in polic; 

● Polica (temno modra), omogoča hiter in enostaven dostop do pogosto uporabljenih orodij. 

Uporabnik si lahko police prilagodi lastnim potrebam; 

● Orodjarna (rumena), vsebuje osnovna orodja ter zadnje uporabljeno orodje. Poleg tega 

lahko v orodjarni prilagajamo izgled delovnega prostora; 

● Delovni prostor (roza), je osrednji del uporabniškega vmesnika, ki je namenjen podvsem 

pogledu v sceno. Prikazuje lahko tudi raznovrstne urejevalnike, ki jih uporabljamo v našem 

delovnem procesu; 

● Okno za kanale (svetlo vijolična), omogoča dostop do atributov predmetov in vozlišč. 

Atribute lahko v tem oknu nastavljamo ter omogočamo njihovo vezavo na ključne časovne 

okvirje; 

● Urejevalnik plasti (temno vijolična), plasti omogočajo združevanje predmetov v skupine, ki 

jih lahko nato obravnavamo ločeno od ostalih plasti. Posamezne plasti lahko skrijemo ali 

celo ločeno upodabljamo; 

● Časovni trak (svetlo modra), omogoča premikanje po časovni dimenziji scene. Na njem 

lahko definiramo ključne okvirje ali si interaktivno ogledamo animirani prizor. Z ukaznimi 

gumbi lahko korakamo po časovnici, sprožimo predvajanje ali nastvimo lastnosti animacije; 

● Ukazna vrstica (oranžna), v ukazni vrstici lahko neposredno izvajamo MEL ali Python 

ukaze; 

● Vrstica pomoči (temno zelena), prikazuje hitro pomoč pri delu z uporabniškim vmesnikom, 

stanje izvedbe akcij, napake in druge informacije. 

Projekti in datoteke 

Projekti 
V Mayi je delo zasnovano projektno. Najbolj smiselno je, da za vsako celostno zadevo ustvarite 

ločen projekt v katerem bodo shranjene tako datoteke z nastavitvami programa, kot vse potrebne 

datoteke za delo. Nov projekt v Mayi ustvarite z menijsko izbiro File –> Project -> New. Pri tem 

morate podati ime projekta in imenik v katerega želite shranjevati vse projektne datoteke (npr. 

Dokumenti\Maya).  Za lokacije posameznih datotek je najbolje, da izberete opcijo Use Defaults. Ko 

ste vpisali nastavitve projekta, pritisnite Accept. S tem ste določili kam se bodo shranjevale vaše 

datoteke (scene v podmapo scenes, slike v podmapo images, itd.). Priporočljivo je, da imena map 

ne vsebujejo presledkov ali posebnih znakov. 

Če delate na več projektih, lahko med njimi preklapljate z menijsko izbiro File -> Project -> Set. 

V kolikor projekta niste definirali, se bodo vaš edatoteke shranjevale v mapo 

mapa_dokumenti\maya\projects\default, kjer je mapa_dokumenti sistemska mapa v kateri se 

nahajajo dokumenti posameznega uporabnika sistema. 
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Vrste datotek v Mayi 
Maya ima nekaj lastnih formatov datotek za shranjevanje podatkov o scenah, slikah, skripath. 

Poleg teh podpira tudi širok nabor drugih formatov, ki jih lahko uporabimo za izmenjavo podatkov 

z ostalimi aplikacijami. 

● Maya binary (.mb) datoteke vsebujejo opis prizora v binarni obliki. V opis so vključeni 

predmeti, teksture, animacije in nekatere druge podrobnosti; 

● Maya IFF (.iff) datoteke so namenjene shranjevanju upodobljenih (bitnih) slik . Poleg 

informacij o barvah posameznih pikslov, lahko datoteka hrani še podatke o globini, maski 

ali še čem drugem; 

● Skripte MEL (.mel) so tekstovne datoteke v katerih so zapisani ukazi Mayinega jezika MEL 

s katerim lahko dopolnemo funkcionalnosti, ki nam jih ponuja uporabniški vmesnik in tako 

npr. porceduralno zgeneriramo določene objekte, algoritmično definiramo izvajanje animacij 

ipd. Enako lahko dosežemo tudi s skriptami Python (.py). 

Pogledi v sceno 

Pri modeliranju scene večinoma delamo v 3D prostoru. Kamere z ortografskim in perspektivnim 

pogledom nam nudijo različne možnosti vpogleda v sceno. 

Privzeti pogledi na sceno: 

 

Premikanje pogleda (kamere) 
Pogled na sceno lahko prilagajamo potrebam tako, da spreminjamo položaj in smer kamere, ki 

določa izbran pogled. 

• Obračanje -  s pritiskom na tipko [ALT] in pritiskom na levi gumb miške [LMG] lahko 

obračamo kamero okoli navpične in vodoravne osi. 

• Premikanje (navpično in vodoravno) – s pritiskom na tipko [ALT] in pritiskom na 

srednji miškin gumb [SMG] lahko premikamo kamero levo/desno ter gor/dol. 

Ortografski p ogledi

(top, front in side)

predstavljajo pravokotno

projekcijo scene na

posamezno ravnino.

Omogočajo nam premikanje

pogleda, ne pa tudi

zasuka.

Perspektivni pogled

omogoča poljubno

premikanje pogleda

v vseh treh dimenzijah,

kot tudi zasuk p ogleda

okoli vodoravne in

navpične osi.
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• Približevanje (angl. zoom) – s pritiskom na tipko [ALT] in pritiskom na desni miškin 

gumb [DMG] lahko kamero premikamo proti ali proč od središča scene. Enako lahko 

dosežemo z uporabo miškinega koleščka [MK]. 

Prikaz predmetov 
Posamezni predmeti so lahko v sceni prikazani različno natančno. S tipkami [1], [2] in [3] 

preklapljamo med različnimi načini prikazovanja modelov, od najbolj grobega do najbolj 

natančnega (zglajenega). 

Prav tako lahko spreminjamo način prikaza/senčenja predmeta. S tipkami [4]-[7] preklaplamo med: 

       

 

Predmeti in komponente 

Scena je sestavljena iz premetov. Med predmete štejemo: krivulje, ploskve, kamere, luči, 

deformacije, … 

Predmeti so sestavljeni iz komponent, kot so na primer kontrolne točke, poligoni, prijemališča in 

podobno. Predmete, ki so prisotni v sceni si lahko ogledamo v oknu Outliner (Window -> Outliner 

ali pa ga izberemo v orodjarni). 

Način dela 
V Mayi lahko s predmeti interaktiramo v dveh načinih: v predmetnem načinu ali v komponentnem 

načinu: 

• Predmetni način -  kjer delamo s predmeti kot celotami: 

 
• Komponentni način -  kjer so vidne tudi posametne komponente predmeta. Predmet je 

glede na tip geometrije lahko sestavljen iz različnih komponent (kontrolnih točk, 

4 – Mrežni prikaz 5 – Barvni prikaz 6 – Prikaz teksture 7 – Prikaz osvetlitve 
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vozlišč/robov/ploskev, ipd.). V sliki je prikazano delo s kontrolnimi točkami: 

 

Med načini dela preklapljamo s pritiskom tipke [F8], z izbiro enega 

izmed gumbov v statusni vrstici (kjer prva ikona predstavlja delo 

z objekti, druga pa delo s komponentami), iz menija dostopnega ob 

kliku z [LMG] na objekt in izbiro ustreznih komponent, kot je 

prikazano v sliki desno. 

Atributi in vozlišča 

Atributi 
Vse lastnosti predmetov in komponent so shranjene kot atributi. Kadar modeliramo, animiramo ali 

kako drugače manipuliramo s predmeti posredno ali neposredno spreminjamo atribute. Atribute 

lahko vidimo ali jih neposredno spreminjamo v oknu za kanale ali v urejevalniku atributov (tipka 

[CTRL + A]). 

   

 

Vozlišča 
Vozlišča so osnovni gradniki pri delovanju Maye. Vozlišča so skupine med seboj sorodnih atributov, 

ki so lahko med seboj povezani in/ali odvisni. Na primer atributi, ki določajo transformacijo 

predmeta, so združeni v transformacijskem vozlišču (angl. transform node). Osnovne vrste vozlišč 

so: 

• Transformacijska vozlišča (angl. transform nodes) – namenjena določanju položaja, 

orientacije in povečave premetov; 

• Vozlišča oblike (angl. shape nodes) – določajo položaj posameznih komponent 

predmeta; 

Okno kanalov Urejevalnik atributov 
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• Vhodna vozlišča (angl. input nodes) – določajo kako so predmeti zgrajeni; 

• Vozlišča senčenja (angl. shading nodes) – določajo lastnosti materialov za posamezne 

predmete. 

Graf odvisnosti 
Predstavlja zbirko vozlišč, ki so med seboj povezana. Graf odvisnosti nam omogoča ugotavljanje in 

povezovanje posameznih vozlišč. Ta graf si lahko ogledamo v oknu Hypergraph (Window -> 

Hypergraph). 

Primitivna telesa 

Primitivna telesa (angl. primitives) so vnaprej pripravljeni predmeti pogosto uporabljenih oblik. 

Maya nudi vrsto osnovnih predmetov, ki jih lahko uporabimo kot osnovo za nadaljnje obilkovanje 

predmetov. Ti primitivi so na primer: krogla (angl. sphere), kocka (angl. cube), valj (angl. 

cylinder), stožec (angl. cone), ravnina (angl. plane), torus, krog (angl, circle), kvadrat (angl. sqare), 

… Primitivi so lahko tipa NURBS, poligonski ali volumetrični. Za posamezni tip primitivov je na 

voljo več ali manj od naštetih. Primitive lahko ustvarimo preko menijev: za NURBS primitive: 

Create->NURBS Primitives->…, za poligonske primitive: Create->Polygon Primitives->…, in za 

volumetrične primitive: Create->Volume Primitives->… 

Preden nek osnovni predmet naredimo, lahko z izbiro na kvadrater poleg menijske opcije določimo 

tudi njegove osnovne parametre, kot so: velikost, natančnost, število komponent ipd. 

Osnovne transformacije in prijemališča  

Med osnovne transformacije sodijo sprememba položaja, orientacije in velikosti 

predmeta/komponente v prostoru. Osnovne transformacije lahko izvajamo z neposrednim 

spreminjanjem atributov (v Oknu kanalov ali Urejevalniku atributov) ali pa s pomočjo 

transformacijskih orodij. Ta orodja so: 

• Orodje za premikanje (angl. move tool) – bljižnica je tipka [W]  

 
• Orodje za obračanje (angl. rotate tool) – bljižnica je tipka [E] 
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• Orodje za povečevanje (angl. scale tool) – bljižnica je tipka [R] 

 

Prijemališča 
Prijemališča (angl. pivoti) so točke v prostoru, ki predstavljajo referenčno točko za izvajanje 

transformacij (npr. točka okoli katere se predmet vrti). Prijemališče lahko urejamo s pritiskom 

tipke [Insert] (oz. [d] na MacOS), ko imamo izbrano katero od orodij osnovnih transformacij. Ko 

smo prijemališče uredili se vrnemo v običano delovanje s ponovnim pritiskom iste tipke. 
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Lekcija 02 

M aya - M odeliranje z NURBS-i 
 

Povzetek 

7. NURBS krivulje 

8. NURBS ploskve 

9. Združevanje objektov (grupiranje) 

10. Delo s komponentami 

11. Uporaba vrtenin (angl. Revolve) 

12. Uporava izvleka (angl. Loft) 

Primer 1: Raketa 

Kot prvi primer dela z Mayo bomo izdelali enostavno raketo. 

Najprej si ustvarimo novo sceno: File->New Scene ali bljižnico [Ctrl + 

N] (na MacOS [Cmd + N]).  

Pokaže se novo okno, na sredi katerega je prikazana prostorska mreža. 

Trenutni pogled je perspektivni in omogoča, da si sceno in predmete v 

njej ogledamo iz vseh strani. Pogled lahko spremenimo s pritiskom na 

tipko [Space], kar nam prikaže 4 poglede (sprednji, stranski, zgornji in 

perspektivni), v želen pogled se povrnemo s tem na nad njega premaknemo miško in ponovno 

pritisnemo preslednico. 

Ogrodje rakete 
Najprej bomo ustvarili ogrodje rakete. Cilj je 

ustvariti valjato telo s konico na zgornjem delu in 

odprtino spodaj. 

Preklopimo v pogled od strani kjer bomo ustvrili 

silhueto naše rakete z uporabo krivulj. V statusni 

vrstici preklopimo v način Modeling nato pa iz 

menije izberemo Create->Curve Tools->EP Curve 

Tool. 

S tem orodjem lahko v stranskem pogledu dodajamo točke, Maya pa bo skoznje potegnila 

prilegajočo krivuljo. Ustvarili bomo zgolj en rob rakete, kot je viden od strani. 

Slika 1: Ustvarjanje nove 

scene. 

Slika 2: Create->Curve Tools->EP Curve Tool  
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Vstavite nekaj točk tako, da boste dobili krivuljo podobno kot je na sliki. 

Po potrebi preklopite na način urejanja komponent [F8] in prestavite 

posamezno točko, da dobite želeni izgled. 

S takšno krivuljo lahko sedaj ustvarimo vrtenino, 

tako da krivuljo zavrtimo okoi osi y in s tem 

oblikujemo trup naše rakete. To storimo tako, da 

uporabimo orodje Revolve. Izberemo krivuljo (naj 

bo zelene barve), nato pa v preko menijev izberite 

Surfaces->Revolve. Kot rezultat dobimo mrežo 

krivulj, kot je razvidno v desni sliki. Če preklopimo 

nazaj v perspektivni pogled vidimo, da smo res 

ustvarili 3D predmet. 

Če sedaj označimo objekt, se nam v Oknu kanalov prikažejo njegove 

lastnosti med katerimi je tudi ime v našem primeru revolvedSurfaceShape1. Maya 

vsakemu novo ustvarjenemu predmetu priredi ime. To ime lahko tudi sami 

spremenimo, kar nam pomaga kasneje, ko imamo v sceni veliko predmetov in 

želimo v seznamu hitro najti želenega. Preimenujmo naš predmet v raketaOgrodje. 

Raketni motor 
V naslednjem koraku bomo ustvarili izpuh motorja rakete. Podobno kot pri 

izdelavi ogrodja bomo tudi tukaj uporabili funkcijo revolve. Postopek je enak, cilj 

pa je dobiti podstavek za raketo podoben tistemu na sliki desno. Tudi temu 

objektu spremenimo ime v izpuhRakete. 

Sedaj lahko združimo ogrodje in izpuh rakete. Izberemo izpuh, pritisnemo tipko 

[W] za premikanje in jo premaknemo tako, da se spoji z ogrodjem rakete. Najlažje 

izpuh premikamo v stranskem pogledu, saj tako najbolje vidimo kdaj je v ustrezni 

legi. 

Za natančnejše premikanje objektov lahko uporabimo Okno kanalov, če pa nam 

zadošča natančnost mreže, lahko vklopimo uporabo mreže (angl. snap to grid) z 

gumbom  v statusni vrstici. To nam omogoča, da točke postavljamo samo na 

mrežo. 

Vidimo lahko, da je po premiku še vedno vidna krivulja, ki smo jo uporabili za 

izdelavo izpuha kar prikazuje tudi slika na desni. V resnici je v sceni tudi krivulja, 

ki smo jo uporabili za izdelavo ogrodja. Obe krivulji lahko brez skrbi pobrišemo, 

saj ju sedaj ne potrebujemo več. To storimo tako, da obe krivulji označimo (več 

objektov sočasno lahko označimo tako, da držimo tipko [Shift] in kliknemo na vse želene objekte) in 

izbrišemo z uporabo tipke [Delete]. 

Če pri svojem delu naredimo napako ali se želimo povrniti v prejšnji korak lahko enostavno 

uporabimo funkcijo razveljavi (angl. undo). Dostopna je preko menija Edit->Undo ali z uporabo 

bljižnice [Ctrl + Z] (na MacOS [Cmd + Z]) ali samo [Z]. Prav tako lahko razveljavljeno akcijo 

ponovno uveljavimo z Edit->Redo oz. Z bljižnico [Ctrl + Shift + Z] ali samo [Shift + Z] (na 

MacOS namesto [Ctrl] uporabimo tipko [Cmd]. 
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Povezovanje predmetov v skupine 
Obe komponenti rakete bomo sedaj povezali v skupino (ju bomo grupirali). To pomeni, da bosta 

oba predmeta povezana, tako da ju lahko premikamo skupaj, jima lahko naenkrat priredimo 

določene lastnosti ipd. 

Najprej oba predmeta označimo in sicer tako, da kliknemo in držimo [LMG] levo zgoraj od ogrodja 

rakete in povlečemo do desno spodnjega dela izpuha rakete ali da kliknemo z [LMG] najprej na en 

predmet, pritisnemo in držimo tipko [Shift] ter nato kliknemo z [LMG] še na drug predmet. 

Sedaj iz menija izberemo Edit->Group ali pritisnemo tipki [Ctrl + G]. Opazimo, da se celotna 

struktura sedaj obarva zeleno, kar nam pove, da je predmet označen, pa tudi v kanalnem oknu se 

pojavi novo ime in sicer group1. Tudi to ime bomo spremenili v nekaj bolj prijaznega in sicer 

raketaTelo. 

Če sedaj kliknemo nekje izven rakete, nato pa ponovno z [LMG] kliknemo nekje na raketi, bi 

pričakovali, da se bo izbrala skupina raketaTelo, vendar se to ne bo zgodilo. Če kliknemo na 

raketaIzpuh ali raketaOgrodje, se bo izbrala le tista komponenta na katero smo kliknili, kar je v 

nasprotju s tistim, o čemer smo govorili pri skupinah. Pomembno je, da se zavedamo, da s tem, ko 

predmet povežemo v skupino, posamezni predmeti iz te skupine ne izgubijo možnosti, da jih 

izberemo posamezno in jim določimo le njim specifične lastnosti. 

Maya uporablja načelo hiearhije, skupina raketaTelo je starš predmetov raketaIzpuh in 

raketaOgrodje, ki sta potomca skupine raketaTelo. Predmeta raketaIzpuh in raketaOgrodje sta si 

sorojenca (angl. sibling). 

Kadar imamo enega izmed sorojencev, lahko do starša dostopamo tako, da pritisnemo puščico 

[Gor], nasprotno lahko do sinov dostopamo s puščico [Dol]. Do sorojencev dostopamo s puščico 

[Levo] ali s puščico [Desno]. 

Izdelava zakrilc 
Zakrilca rakete bomo izdelali s pomočjo sploščenih stožcev, ki jih bomo dodatno preoblikovali. 

Najprej dosedanji model rakete prestavimo iz koordinatnega izhodišča, da 

bomo v njem lahko ustvarili en primerek zakrilca. Iz menija izberemo 

Create->NURBS Primitives->Cone □ (kliknemo na kvadratek ob izbiri). 

To nam omogoča, da definiramo osnovne lastnosti stožca. Določimo 

lastnosti: 

• Axis: Y 

• Radius: 1.5 

• Height: 3 

pritisnemo Apply. S tem smo v koordinatnem izhodišču ustvarili stožec z 

želenimi lastnostmi. Preimenujemo ga v raketaKrilo1. 

To seveda še ni zakrilce, saj bi moral biti nekoliko zasukan, manjši in sploščen. 

Zasučemo ga za 120º okoli osi x v Oknu kanalov. Nato ga še sploščimo tako, da 

ga skaliramo v isti smeri na 1/5 originalne vrednosti tako, da v Oknu kanalov 

pod atributom Scale X vpišemo vrednost 0.2. Zakrilce še nekoliko zmanjšamo v 

smereh y in z in sicer na vrednost 0.75. 

Krilo pomaknemo v raketo, tako da plašč stožca delno sega iz rakete, dno pa je 

povsem skrito kot prikazuje slika.  
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Izdelati želimo še 5 kril in jih enakomerno razporediti okoli trupa rakete. To bomo storili z uporabo 

orodja za podvajanje (angl. duplicate), ki nam omogoča, da želen objekt namnožimo poljubno 

mnogokrat. Z dodatnimi nastavitvami pa lahko dosežemo še posebno obnašanje funkcije 

podvajanja, ki omogoča postavljanje duplikatov na želena mesta. 

Prijemališča 
Preden se lotimo podvajanja predmetov pogljemo kjer se nahajajo prijemališča posameznih 

predmetov. Kot smo že omenili, so prijemališča referenčne točke okoli katerih delujejo 

transformacije. 

Podvajanje zakrilc 
Da bi krila naredili na čimbolj eleganten način s čim manj dodatnega 

dela bomo eno zakrilce, ki ga že imamo 5x namnožili in vsakič zasukali 

za 60º okoli središča rakete. 

Privzeto je prijemališče posameznega predmeta v njegovem središču. V 

primeru stožca je to npr. v središču osnovne ploskve. Če želimo torej 

stožec namnožiti okoli središča rakete, moramo njegovo prijemališče 

prestaviti v središče rakete. To storimo tako, da se prestavimo v pogled 

od zgoraj, pritisnemo tipko [d] za manipulacijo s prijemališčem in ga 

prestavimo čimbližje središču rakete. Za pomoč lahko preklopimo v mrežni način 

izrisa s pritiskom na tipko [4]. 

Poskrbimo, da je zakrilce še vedno izbrano in iz menija izberemo Edit->Duplicate 

Special □.V drugem stolpcu vrstice Rotate vnesemo vrednost 60 (drugi stolpec 

predstavlja rotacijo okoli osi y). V polje Number of Copies vnesemo vrednost 5 in 

pritisnemo gumb Apply. Kot rezultat dobimo 5 novih zakrilc na ustreznih mestih.  

Za konec nam preostane le še, da skupaj označimo vse objekte naredimo novo 

skupino raketa in sceno shranimo z izbiro iz menija File->Save.  

Primer 2: Čolniček 

V drugem primeru bomo znanje prvega primera nadgradili še z drugimi zelo uporabnimi funkcijami 

ter usvarili enostaven čolniček. 

Ogrodje 
Kot pri raketi bi lahko tudi v primeru čolnička najprej ustvarili ogrodje z uporabo orodja revolve. 

Pri nastavitvah orodja bi nastavili, da se krivulja zasuče zgolj za 180º. Namesto tega bomo spoznali 

urejanje komponent. 

Za osonovo bomo uporabili polovico stožca, ki ga ustvarimo tako, da v meniju izberemo Create-

>NURBS Primitives->Cone □. Določimo naslednje lastnosti: 

• axis: z 

• end sweep angle: 180 (s tem bomo dobili samo polovico stožca) 

• radius: 1 

• height: 2 
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• number of sections: 8 

• number of spans: 4 

• caps: bottom 

• označite še Extra transform on Caps 

Nato pritisnite Create. V kooddinatnem izhodišču se vam bo 

pojavil stožec kot je prikazan na sliki desno. 

Če si stožec ogledamo bolj natančno vidimo, da je sestavljen iz več likov, v vodoravni smeri iz 

osmih, v navpični pa iz štirih, kar ustreza nastavitvam orodja za kreiranje. 

Te nastavitve nam do tega trenutka niso bile pomembne, so pa pri modeliranju zelo pomembne, saj 

vsako presečišče dveh zelenih črt na sliki pomeni eno točko, ki jo lahko ročno premikamo in s tem 

spreminjamo celoten predmet. Kako se to uporablja bomo videli v nadaljevanju. 

Najprej pa bomo naš stožec še malce predelali. V Oknu kanalov ga bomo transformirali tako, da 

bomo v okno Scale X vnesli 0.5, v okno Scale Y 0.75 in v Scale Z 1.5. S tem smo naš čolniček 

škrčili, mu zmanjšali globino in ga podaljšali. 

Sedaj bomo pa stožec ročno spremenili tako, da bo bolj podoben trupu čolna. Najprej spremenite 

pogled v stranski pogled. 

Če imate vklopljeno senčenje, ga izklopite s tipko [4]. 

Označimo predmet in s tipko [F8] preklopimo v način 

Urejanje po komponentah ali Component Selection Mode. Na 

zaslonu imamo sedaj sliko podobno tej na sliki na desni. 

Da nek predmet približamo tako, da je v celoti v našem 

pogledu, dosežemo tako, da ga označimo nato pa pritisnemo tipko [F] ali [A]. 

Najprej opazimo vijolične točke. Te točke so kontrolne točke ali control vertices (CV) in nam 

omogočajo, da lahko natančno modeliramo nek predmet. 

Predmet bomo oblikovali tako, da omo od desne proti 

levi izbirali točke ter jih premikali tako, da bomo na 

koncu dobili nekaj podobnega kot je prikazano na sliki 

na desni. 

Pri premikanju kontrolnih točk moramo paziti, da točke vedno izbiramo s pomočjo miške, tako da 

pritisnemo in držimo [LMG] levo-zgoraj od izbrane točke ter povlečemo do položaja desno-spodaj, 

glede na točko. Temu bomo v bodoče rekli marquee izbira. Točke moramo izbirati na ta način zato, 

ker moramo upoštevati, da gledamo predmet iz strani, kar pomeni, da so na nasprotni (nevidni) 

strani istoležeče točke, ki jih na tak način prav tako izberemo in premaknemo, s čimer zagotovimo 

simetričnost. 
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Sedaj bomo spremenili pogled v zgornji in naš čolniček malce razširili ter mu s 

tem dali končno obliko. Kot pri urejanju iz strani tudi tukaj marquee 

izbiramo točke ter jih premikamo tako, da dobimo sliko podobno sliki na 

desni. 

Ko končamo, izklopimo urejanje po komponentah s tipko [F8]. 

Če čoln pogledamo v perspektivnem pogledu vidimo, da je izdelek že precej 

realističen, vendar moramo predmetu dodati še debelino materiala s katerim 

je narejen. 

Najprej bomo duplicirali že narejeno ogrodje, ga pomanjšali in zapolnili luknje 

med obema predmetoma, kar nam bo dalo občutek, da je predmet narejen iz realnega materiala, 

kot sta železo ali les, ne pa iz zelo tankega, kot je npr. papir. 

Označimo naše ogrodje in iz menija izberemo Edit->Duplicate Special □. Če se spomnite prvega 

primera – rakete, veste, da smo funkcijo duplicate že uporabili ter da smo ji nastavili nekatere 

posebne lastnosti. Maya ima to lastnost, da si te nastavitve zapomni tako dolgo, dokler jih ne 

spremenimo. 

Zato znotraj okna Duplicate Special, iz menija izberite 

Edit->Reset Settings ter nato Duplicate. S tem bomo 

predmet, ki je enak našemu ogrodju in ki leži na istem 

mestu, kot naše ogrodje. Novo ustvarjeni predmet je 

tudi že avtomatsko izbran, zato ga ni potrebno ponovno 

izbirati. 

Novi predmet bomo sedaj nekoliko zmanjšali in sicer 

tako, da bomo v kanalsko okno vpisali: scale X – 0.8, 

scale Y – 0.8, scale Z – 0.9. Po končanem dupliciranju 

in pomanjševanju dobimo sliko podobno sliki desno. 

Opazimo lahko, da je ena stran površin temna, druga 

pa siva. Vedeti moramo, da Maya loči med notranjo in 

zunanjo stranjo površin. Zato je potrebno notranji 

čolniček obrniti. To dosežemo tako, da ga označimo in 

iz menija izberemo Surfaces->Reverse Directions. Kot 

rezultat dobimo pravilno orientirane površine prikazane 

desno. 

Loft 
Sedaj nam preostane še to, da med seboj povežemo notranji in zunanji del čolnička. To bomo 

naredili z uporabo funkcije Loft. Za povezovenje površin z orodjem loft moramo označiti robni 

krivulji posamezne površine. To dosežemo tako, da na posamezno lupinico kliknemo z [DMG] in 

izberemo isoparm. Mreža obeh lupinic se bo tako obarvala modro. V tem načinu lahko s klikom in 

tipko [Shift] izbremo robni krivulji, ki ju želimo povezati. Ko sta izbrani se obarvata rumeno. 

Takrat iz menija izberemo Surfaces->Loft. Ustvari se nova površina, ki povezuje označeni krivulji. 

Če je površina temna je obrnjena narobe in jo moramo obrniti na enak način, kot smo že opisali 

zgoraj. Ta postopek ponovimo za vse manjkajoče površine. 

Spodnja slika prikazuje zaporedje korakov in pa končni izdelek. 
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Lekcija 02 

M aya - M odeliranje z NURBS-i 
 

Povzetek 

13. NURBS krivulje 

14. NURBS ploskve 

15. Združevanje objektov (grupiranje) 

16. Delo s komponentami 

17. Uporaba vrtenin (angl. Revolve) 

18. Uporava izvleka (angl. Loft) 

Primer 1: Raketa 

Kot prvi primer dela z Mayo bomo izdelali enostavno raketo. 

Najprej si ustvarimo novo sceno: File->New Scene ali bljižnico [Ctrl + 

N] (na MacOS [Cmd + N]).  

Pokaže se novo okno, na sredi katerega je prikazana prostorska mreža. 

Trenutni pogled je perspektivni in omogoča, da si sceno in predmete v 

njej ogledamo iz vseh strani. Pogled lahko spremenimo s pritiskom na 

tipko [Space], kar nam prikaže 4 poglede (sprednji, 

stranski, zgornji in perspektivni), v želen pogled se 

povrnemo s tem na nad njega premaknemo miško 

in ponovno pritisnemo preslednico. 

Slika 3: Ustvarjanje nove 

scene. 
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Ogrodje rakete 
Najprej bomo ustvarili ogrodje rakete. Cilj je ustvariti valjato telo s konico na zgornjem delu in 

odprtino spodaj. 

Preklopimo v pogled od strani kjer bomo ustvrili silhueto naše rakete z uporabo krivulj. V statusni 

vrstici preklopimo v način Modeling nato pa iz menije izberemo Create->Curve Tools->EP Curve 

Tool. 

S tem orodjem lahko v stranskem pogledu 

dodajamo točke, Maya pa bo skoznje potegnila 

prilegajočo krivuljo. Ustvarili bomo zgolj en rob rakete, kot je viden od strani. 

Vstavite nekaj točk tako, da boste dobili krivuljo podobno kot je na sliki. 

Po potrebi preklopite na način urejanja komponent [F8] in prestavite 

posamezno točko, da dobite želeni izgled. 

S takšno krivuljo lahko sedaj ustvarimo vrtenino, 

tako da krivuljo zavrtimo okoi osi y in s tem 

oblikujemo trup naše rakete. To storimo tako, da 

uporabimo orodje Revolve. Izberemo krivuljo (naj 

bo zelene barve), nato pa v preko menijev izberite 

Surfaces->Revolve. Kot rezultat dobimo mrežo 

krivulj, kot je razvidno v desni sliki. Če preklopimo 

nazaj v perspektivni pogled vidimo, da smo res 

ustvarili 3D predmet. 

Če sedaj označimo objekt, se nam v Oknu kanalov prikažejo njegove 

lastnosti med katerimi je tudi ime v našem primeru revolvedSurfaceShape1. Maya 

vsakemu novo ustvarjenemu predmetu priredi ime. To ime lahko tudi sami 

spremenimo, kar nam pomaga kasneje, ko imamo v sceni veliko predmetov in 

želimo v seznamu hitro najti želenega. Preimenujmo naš predmet v raketaOgrodje. 

Raketni motor 
V naslednjem koraku bomo ustvarili izpuh motorja rakete. Podobno kot pri 

izdelavi ogrodja bomo tudi tukaj uporabili funkcijo revolve. Postopek je enak, cilj 

pa je dobiti podstavek za raketo podoben tistemu na sliki desno. Tudi temu 

objektu spremenimo ime v izpuhRakete. 

Sedaj lahko združimo ogrodje in izpuh rakete. Izberemo izpuh, pritisnemo tipko 

[W] za premikanje in jo premaknemo tako, da se spoji z ogrodjem rakete. Najlažje 

izpuh premikamo v stranskem pogledu, saj tako najbolje vidimo kdaj je v ustrezni 

legi. 

Za natančnejše premikanje objektov lahko uporabimo Okno kanalov, če pa nam 

zadošča natančnost mreže, lahko vklopimo uporabo mreže (angl. snap to grid) z 

gumbom  v statusni vrstici. To nam omogoča, da točke postavljamo samo na 

mrežo. 

Vidimo lahko, da je po premiku še vedno vidna krivulja, ki smo jo uporabili za 

izdelavo izpuha kar prikazuje tudi slika na desni. V resnici je v sceni tudi krivulja, 

ki smo jo uporabili za izdelavo ogrodja. Obe krivulji lahko brez skrbi pobrišemo, 

saj ju sedaj ne potrebujemo več. To storimo tako, da obe krivulji označimo (več 

Slika 4: Create->Curve Tools->EP Curve Tool  
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objektov sočasno lahko označimo tako, da držimo tipko [Shift] in kliknemo na vse želene objekte) in 

izbrišemo z uporabo tipke [Delete]. 

Če pri svojem delu naredimo napako ali se želimo povrniti v prejšnji korak lahko enostavno 

uporabimo funkcijo razveljavi (angl. undo). Dostopna je preko menija Edit->Undo ali z uporabo 

bljižnice [Ctrl + Z] (na MacOS [Cmd + Z]) ali samo [Z]. Prav tako lahko razveljavljeno akcijo 

ponovno uveljavimo z Edit->Redo oz. Z bljižnico [Ctrl + Shift + Z] ali samo [Shift + Z] (na 

MacOS namesto [Ctrl] uporabimo tipko [Cmd]. 

Povezovanje predmetov v skupine 
Obe komponenti rakete bomo sedaj povezali v skupino (ju bomo grupirali). To pomeni, da bosta 

oba predmeta povezana, tako da ju lahko premikamo skupaj, jima lahko naenkrat priredimo 

določene lastnosti ipd. 

Najprej oba predmeta označimo in sicer tako, da kliknemo in držimo [LMG] levo zgoraj od ogrodja 

rakete in povlečemo do desno spodnjega dela izpuha rakete ali da kliknemo z [LMG] najprej na en 

predmet, pritisnemo in držimo tipko [Shift] ter nato kliknemo z [LMG] še na drug predmet. 

Sedaj iz menija izberemo Edit->Group ali pritisnemo tipki [Ctrl + G]. Opazimo, da se celotna 

struktura sedaj obarva zeleno, kar nam pove, da je predmet označen, pa tudi v kanalnem oknu se 

pojavi novo ime in sicer group1. Tudi to ime bomo spremenili v nekaj bolj prijaznega in sicer 

raketaTelo. 

Če sedaj kliknemo nekje izven rakete, nato pa ponovno z [LMG] kliknemo nekje na raketi, bi 

pričakovali, da se bo izbrala skupina raketaTelo, vendar se to ne bo zgodilo. Če kliknemo na 

raketaIzpuh ali raketaOgrodje, se bo izbrala le tista komponenta na katero smo kliknili, kar je v 

nasprotju s tistim, o čemer smo govorili pri skupinah. Pomembno je, da se zavedamo, da s tem, ko 

predmet povežemo v skupino, posamezni predmeti iz te skupine ne izgubijo možnosti, da jih 

izberemo posamezno in jim določimo le njim specifične lastnosti. 

Maya uporablja načelo hiearhije, skupina raketaTelo je starš predmetov raketaIzpuh in 

raketaOgrodje, ki sta potomca skupine raketaTelo. Predmeta raketaIzpuh in raketaOgrodje sta si 

sorojenca (angl. sibling). 

Kadar imamo enega izmed sorojencev, lahko do starša dostopamo tako, da pritisnemo puščico 

[Gor], nasprotno lahko do sinov dostopamo s puščico [Dol]. Do sorojencev dostopamo s puščico 

[Levo] ali s puščico [Desno]. 

Izdelava zakrilc 
Zakrilca rakete bomo izdelali s pomočjo sploščenih stožcev, ki jih bomo dodatno preoblikovali. 

Najprej dosedanji model rakete prestavimo iz koordinatnega izhodišča, da 

bomo v njem lahko ustvarili en primerek zakrilca. Iz menija izberemo 

Create->NURBS Primitives->Cone □ (kliknemo na kvadratek ob izbiri). 

To nam omogoča, da definiramo osnovne lastnosti stožca. Določimo 

lastnosti: 

• Axis: Y 

• Radius: 1.5 

• Height: 3 

pritisnemo Apply. S tem smo v koordinatnem izhodišču ustvarili stožec z želenimi lastnostmi. 

Preimenujemo ga v raketaKrilo1. 
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To seveda še ni zakrilce, saj bi moral biti nekoliko zasukan, manjši in sploščen. 

Zasučemo ga za 120º okoli osi x v Oknu kanalov. Nato ga še sploščimo tako, da 

ga skaliramo v isti smeri na 1/5 originalne vrednosti tako, da v Oknu kanalov 

pod atributom Scale X vpišemo vrednost 0.2. Zakrilce še nekoliko zmanjšamo v 

smereh y in z in sicer na vrednost 0.75. 

Krilo pomaknemo v raketo, tako da plašč stožca delno sega iz rakete, dno pa je 

povsem skrito kot prikazuje slika.  

Izdelati želimo še 5 kril in jih enakomerno razporediti okoli trupa rakete. To 

bomo storili z uporabo orodja za podvajanje (angl. duplicate), ki nam omogoča, da želen objekt 

namnožimo poljubno mnogokrat. Z dodatnimi nastavitvami pa lahko dosežemo še posebno 

obnašanje funkcije podvajanja, ki omogoča postavljanje duplikatov na želena mesta. 

Prijemališča 
Preden se lotimo podvajanja predmetov pogljemo kjer se nahajajo prijemališča posameznih 

predmetov. Kot smo že omenili, so prijemališča referenčne točke okoli katerih delujejo 

transformacije. 

Podvajanje zakrilc 
Da bi krila naredili na čimbolj eleganten način s čim manj dodatnega 

dela bomo eno zakrilce, ki ga že imamo 5x namnožili in vsakič zasukali 

za 60º okoli središča rakete. 

Privzeto je prijemališče posameznega predmeta v njegovem središču. V 

primeru stožca je to npr. v središču osnovne ploskve. Če želimo torej 

stožec namnožiti okoli središča rakete, moramo njegovo prijemališče 

prestaviti v središče rakete. To storimo tako, da se prestavimo v pogled 

od zgoraj, pritisnemo tipko [d] za manipulacijo s prijemališčem in ga 

prestavimo čimbližje središču rakete. Za pomoč lahko preklopimo v mrežni način 

izrisa s pritiskom na tipko [4]. 

Poskrbimo, da je zakrilce še vedno izbrano in iz menija izberemo Edit->Duplicate 

Special □.V drugem stolpcu vrstice Rotate vnesemo vrednost 60 (drugi stolpec 

predstavlja rotacijo okoli osi y). V polje Number of Copies vnesemo vrednost 5 in 

pritisnemo gumb Apply. Kot rezultat dobimo 5 novih zakrilc na ustreznih mestih.  

Za konec nam preostane le še, da skupaj označimo vse objekte naredimo novo 

skupino raketa in sceno shranimo z izbiro iz menija File->Save.  

Primer 2: Čolniček 

V drugem primeru bomo znanje prvega primera nadgradili še z drugimi zelo uporabnimi funkcijami 

ter usvarili enostaven čolniček. 

Ogrodje 
Kot pri raketi bi lahko tudi v primeru čolnička najprej ustvarili ogrodje z uporabo orodja revolve. 

Pri nastavitvah orodja bi nastavili, da se krivulja zasuče zgolj za 180º. Namesto tega bomo spoznali 

urejanje komponent. 



  

19 | FRI |  3D modeliranje z orodjem Autodesk Maya 

Za osonovo bomo uporabili polovico stožca, ki ga ustvarimo tako, da v meniju izberemo Create-

>NURBS Primitives->Cone □. Določimo naslednje lastnosti: 

• axis: z 

• end sweep angle: 180 (s tem bomo dobili samo polovico stožca) 

• radius: 1 

• height: 2 

• number of sections: 8 

• number of spans: 4 

• caps: bottom 

• označite še Extra transform on Caps 

Nato pritisnite Create. V kooddinatnem izhodišču se vam bo 

pojavil stožec kot je prikazan na sliki desno. 

Če si stožec ogledamo bolj natančno vidimo, da je sestavljen iz več likov, v vodoravni smeri iz 

osmih, v navpični pa iz štirih, kar ustreza nastavitvam orodja za kreiranje. 

Te nastavitve nam do tega trenutka niso bile pomembne, so pa pri modeliranju zelo pomembne, saj 

vsako presečišče dveh zelenih črt na sliki pomeni eno točko, ki jo lahko ročno premikamo in s tem 

spreminjamo celoten predmet. Kako se to uporablja bomo videli v nadaljevanju. 

Najprej pa bomo naš stožec še malce predelali. V Oknu kanalov ga bomo transformirali tako, da 

bomo v okno Scale X vnesli 0.5, v okno Scale Y 0.75 in v Scale Z 1.5. S tem smo naš čolniček 

škrčili, mu zmanjšali globino in ga podaljšali. 

Sedaj bomo pa stožec ročno spremenili tako, da bo bolj podoben trupu čolna. Najprej spremenite 

pogled v stranski pogled. 

Če imate vklopljeno senčenje, ga izklopite s tipko [4]. 

Označimo predmet in s tipko [F8] preklopimo v način 

Urejanje po komponentah ali Component Selection Mode. Na 

zaslonu imamo sedaj sliko podobno tej na sliki na desni. 

Da nek predmet približamo tako, da je v celoti v našem 

pogledu, dosežemo tako, da ga označimo nato pa pritisnemo tipko [F] ali [A]. 

Najprej opazimo vijolične točke. Te točke so kontrolne točke ali control vertices (CV) in nam 

omogočajo, da lahko natančno modeliramo nek predmet. 

Predmet bomo oblikovali tako, da omo od desne proti 

levi izbirali točke ter jih premikali tako, da bomo na 

koncu dobili nekaj podobnega kot je prikazano na sliki 

na desni. 

Pri premikanju kontrolnih točk moramo paziti, da točke vedno izbiramo s pomočjo miške, tako da 

pritisnemo in držimo [LMG] levo-zgoraj od izbrane točke ter povlečemo do položaja desno-spodaj, 

glede na točko. Temu bomo v bodoče rekli marquee izbira. Točke moramo izbirati na ta način zato, 

ker moramo upoštevati, da gledamo predmet iz strani, kar pomeni, da so na nasprotni (nevidni) 

strani istoležeče točke, ki jih na tak način prav tako izberemo in premaknemo, s čimer zagotovimo 

simetričnost. 
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Sedaj bomo spremenili pogled v zgornji in naš čolniček malce razširili ter mu s 

tem dali končno obliko. Kot pri urejanju iz strani tudi tukaj marquee 

izbiramo točke ter jih premikamo tako, da dobimo sliko podobno sliki na 

desni. 

Ko končamo, izklopimo urejanje po komponentah s tipko [F8]. 

Če čoln pogledamo v perspektivnem pogledu vidimo, da je izdelek že precej 

realističen, vendar moramo predmetu dodati še debelino materiala s katerim 

je narejen. 

Najprej bomo duplicirali že narejeno ogrodje, ga pomanjšali in zapolnili luknje 

med obema predmetoma, kar nam bo dalo občutek, da je predmet narejen iz realnega materiala, 

kot sta železo ali les, ne pa iz zelo tankega, kot je npr. papir. 

Označimo naše ogrodje in iz menija izberemo Edit->Duplicate Special □. Če se spomnite prvega 

primera – rakete, veste, da smo funkcijo duplicate že uporabili ter da smo ji nastavili nekatere 

posebne lastnosti. Maya ima to lastnost, da si te nastavitve zapomni tako dolgo, dokler jih ne 

spremenimo. 

Zato znotraj okna Duplicate Special, iz menija izberite 

Edit->Reset Settings ter nato Duplicate. S tem bomo 

predmet, ki je enak našemu ogrodju in ki leži na istem 

mestu, kot naše ogrodje. Novo ustvarjeni predmet je 

tudi že avtomatsko izbran, zato ga ni potrebno ponovno 

izbirati. 

Novi predmet bomo sedaj nekoliko zmanjšali in sicer 

tako, da bomo v kanalsko okno vpisali: scale X – 0.8, 

scale Y – 0.8, scale Z – 0.9. Po končanem dupliciranju 

in pomanjševanju dobimo sliko podobno sliki desno. 

Opazimo lahko, da je ena stran površin temna, druga 

pa siva. Vedeti moramo, da Maya loči med notranjo in 

zunanjo stranjo površin. Zato je potrebno notranji 

čolniček obrniti. To dosežemo tako, da ga označimo in 

iz menija izberemo Surfaces->Reverse Directions. Kot 

rezultat dobimo pravilno orientirane površine prikazane 

desno. 

Loft 
Sedaj nam preostane še to, da med seboj povežemo notranji in zunanji del čolnička. To bomo 

naredili z uporabo funkcije Loft. Za povezovenje površin z orodjem loft moramo označiti robni 

krivulji posamezne površine. To dosežemo tako, da na posamezno lupinico kliknemo z [DMG] in 

izberemo isoparm. Mreža obeh lupinic se bo tako obarvala modro. V tem načinu lahko s klikom in 

tipko [Shift] izbremo robni krivulji, ki ju želimo povezati. Ko sta izbrani se obarvata rumeno. 

Takrat iz menija izberemo Surfaces->Loft. Ustvari se nova površina, ki povezuje označeni krivulji. 

Če je površina temna je obrnjena narobe in jo moramo obrniti na enak način, kot smo že opisali 

zgoraj. Ta postopek ponovimo za vse manjkajoče površine. 

Spodnja slika prikazuje zaporedje korakov in pa končni izdelek. 
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Lekcija 03 

Maya - Modeliranje s poligoni 
 

Povzetek 

1. Poligoni 

2. Robovi 

3. Vozlišča 

4. Izvlek 

5. Ustvarjanje poligona 

6. Glajenje mrežne geometrije 

 

Za razliko od modeliranja s krivuljami in površinami je bilo modeliranje z mrežno geometrijo 

razvito za povsem druge namene, saj ima mrežna geometrija omejeno natančnost pri upodobitvah 

ukrivljenih površin. Seveda lahko z dodajanjem podrobnosti natančnost poljubno povečujemo, a to 

ni osnovni namen tehnike. Osnovne komponente mrežne geometrije so: vozlišča (angl. vertices), 

robovi (angl. edges), in lica (angl. faces), ki so praviloma sestavljena iz mnogokotnikov (angl. 

polygons). 

Kaj so poligoni? 

Poligoni ali mnogokotniki so liki s tremi ali več oglišči. V 

resnici se vsi mnogokotniki z več kot tremi oglišči pred 

izrisom pretvorijo v trikotnike in šele nato izrišejo. Razlog za 

to leži predvsem v zasnovi grafčnih cevovodov in zaradi 

potrebe po enolični definiciji objektov.  

Poligonska geometrija je še vedno prevladujoč način 

predstavitve 3D objektov in je najbolj razširjen predvsem 

zaradi uporabe v 3D interaktivni računalniški grafiki (npr. v 

računalniških igrah). Posledično je z oblikovanje takšne 3D 

geometrije na voljo veliko različnih orodij in pripomočkov. V 

nadaljevanju si bomo pogledali kako lahko takšno geometrijo 

oblikujemo na nanjnižjem nivoju - s premikanjem posameznih 

oglišč. 

Posamezen trikotnik je sestavljen iz osnovnih gradnikov: (1) 

oglišč (angl. vertices), (2) (angl. edges), in (3) lica (angl. faces), 

kar je prikazano tudi na desni sliki. 

Kot smo že spoznali, nam Maya ponuja nabor osnovnih primitivov za izhodišče pri 3D modeliranju 

(kocka, valj, stožec, …). Večina teh gradnikov je lahko definiranih tudi s poligoni. Pri modeliranju z 

oglišča robovi

ploskev oz. lice
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uporabo poligonov tako za izhodišče vzamemo po obliki najbližji primitiv, ki ga nato izoblikujemo v 

končno željeno obliko. 

Zakaj poligoni? 

Kot smo omenili že v prejšnjem poglavju je poglavitni razlog za njihovo uporabo njihova visoka 

razširjenost in posledično prilagojenost tako programske kot strojne opreme. Nenazadnje so grafične 

kartice močno optimizirane ravno za izris 3D geometrije predstavljene s poligoni. 

Zelo pozitivna lastnost je kompaktnost predstavitve. Kompleksnejšo 3D geometrijo lahko iz 

poligonov oblikujemo tako, da na mestih kjer želimo več podrobnosti uporabimo večje število 

poligonov, kjer pa takšne potrebe ni, lahko uporabimo manjše število poligonov. 

Zelo priročni so tudi zaradi dejstva, da je na poligone zelo enostavno “lepiti” teksture - slike ki 

predstvljajo podrobnejšo strukturo objektov in določajo tudi njihovo barvo ter izgled. Z leti se je 

razvilo tudi veliko tehnik, ki nam omogočajo, da sicer grobo definiranim 3D modelom dodamo 

dodatne navidezne podrobnosti (npr. z uporabo izboklin, zamikanja, mapiranja normal). Prednosti 

je še veliko, a jih bomo v okviru delavnice spoznali le majhen izbor. 

Ustvarjanje poligonskih modelov 

Za ustvarjanje poligonske geometrije moramo pričeti z enim izmed primitivov, ki nam je na voljo. 

Nabolj preprost je primitiv ravnine, ki je predstavljena s štirimi oglišči, 4 robovi in eno ploskvijo. 

Za ustvrjanje novih poligonov moramo takšno začetno geometrijo spremeniti v načinu za urejanje, 

kar je predstavljeno v naslednjem poglavju. 

Kot izhodiščni primitiv je najbolj smiselno izbrati primitiv, ki najbolje predstavlja obliko in 

lastnosti žlenega končnega izdelka. Za izdelavo obraza lahko tako pričnemo s kocko ali sfero (oba 

sta dobro izhodišče), za podolgovate predmete je praviloma najbolje izbrati valj ali podolgovat 

kvader ipd. 

Primer 1: Vesoljska ladja 

Osnove modeliranja bomo spoznali preko modeliranja enostavne vesoljske ladje kjer bomo za 

osnovo vzeli kocko. Kocka je v osnovi sestavljena iz 6-ih lic, 12-ih robov in 8-ih vozlišč. 

Poligoni 
Medtem, ko je bila raketa v prvi lekciji sestavljena iz množice krivulj in površin, bomo za 

modeliranje vesoljske ladje uporabili poligone, ki so sestavljeni iz trikotnikov. Razlog za to tiči v 

primernosti takšne geometrije za realno-časovno upodabljanje, saj je strojna oprema močno 

prilagojena procesiranju tako definirane geometrije. 

Modeliranje 
Za začetek bomo ustvarili novo poligonsko kocko Create->Polygon 

Primitives->Cube. Če nismo spreminjali osnovnih lastnosti orodja se bo v 

središču scene pojavila kocka z robom 1 enoto kot je prikazana v sliki 

desno. 
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Kot smo že dejali v uvodu poglavja ima kocka različne komponente, ki so vidne v spodnjih slikah: 

 

                           Lica                            Robovi                        Vozlišča 

Osnovno obliko mrežne geometrije lahko preoblikujemo že s samim urejanjem komponent. Preden 

pa se lotimo tega, bomo pokazali kako lahko modeliramo z mrežno geometrijo z nekaterimo orodji, 

ki jih ponuja Maya. 

Izvlek 
Najpogostejše uporabljeno orodje pri modeliranju s poligoni je izvlek (angl. extrude). S tem 

orodjem lahko označen poligon ali več poligonov izvlečemo iz modela v smeri njegove normale in 

tako ustvarimo nova lica v geometriji. Orodje za Primer izvleka je prikazan v spodnji sliki. 

 

Oboje uporabljamo v kompnentnem načinu, ki prikazuje lica (desni gumb na predmet in izberemo 

face). Označimo eno ali več lic, nato pa v meniju izberemo Edit Mesh->Extrude (ali uporabimo 

bljižnico [Ctrl+E], na Mac-u [Cmd+E]). Pojavi se nam poseben manipulator, ki nam omogoča, da 

izvlečemo lice in ga premaknemo relativno glede na izvorno. Največkrat ga izvlečemo v smeri 

modrega minipulatorja. Lice lahko sočasno tudi povečamo/pomanjšamo. S tem orodjem bomo v 

nadeljevanju izdelali celotno vesoljsko ladjo. 

Izdelava vesoljske ladje 
Najprej kocko s skalacijo vzdolž ene dimenzije spremenimo v kvader. Nato označimo robni lici 

kvadra in ju izvlečemo ter nekoliko skrčimo v navpični smeri. Nato ponovno izvlečemo obe novi 

lici, ki ju prav tako skrčimo, poleg tega pa še premaknemo nazaj. Za ponovno uporabo istega 

orodja lahko uporabimo kar bljižnico [G]. 

 

Nato naredimo trikrat izvlek osrednjega sprednjega lica in zadnjega nekoliko pomanjšamo v devh 

smereh. Označimo liči ob izvlečenem nosu, sprožimo izvlek in ju malenkost pomanjšamo. Z 

naslednjim izvlekom obeh lic ju poglobimo v notranjost ladje. S tem smo dodali odprtine za vnos 

zraka pri letu v atmosrefi. Izvlečemo še pilotsko kabino. 
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Dodamo še repno krilo, ki ga izvlečemo iz zadnjega zgornjega dela trupa, kjer s prvim izvlekom 

najprej zmanjšamo lice, z drugim izvlekom pa izvlečemo repno krilo, ki ga na vrhu zožamo in 

pomaknemo nazaj. V zadnjem koraku dodamo še pogonsko odprtino glavnega motorja, ki jo 

izdelamo enako kot odprtini za vnos zraka. 

 

Naša vesoljska ladja je izredno oglata. Da dobimo nekoliko bolj realističen izgled jo je potrebno 

zgladiti. Da si ogledamo predogled zglajenega modela lahko uporabimo že znano funkcionalnost 

Maye, kjer lahko preklapljamo med tremi stopnjamo podrobnega prikaza modela s tipkami [1], [2] 

in [3] kot prikazujejo spodnje slike. Takšna vesoljka ladja zgleda že bolj realistično, izdelamo pa jo 

lahko v nekaj minutah. 

 

Pri tem se moramo zavedati, da mrežne geometrije nismo tudi dejansko zgladili kar moramo pred 

želeno končno upodobitvijo tudi izvesti. 

Glajenje 
Glajenje mreže (angl. Mesh Smooth) je postopek 

podrobnejše delitve mrežne geometrije, ki posamezno 

lice naše mreže razdeli na več lic, pri tem pa vmesna 

vozlišča postavi na takšne položaje, da se oblika 

modela zgladi. V Mayi nam je na razpolago linearno in 

eksponentno glajenje, vsakemu pa lahko nastavimo 

vrsto parametrov. Če v meniju izberemo Mesh-

>Smooth □ lahko izbiramo med nastavitvami glajenja. 

Privzeto Maya gladi z eksponentno metodo s 3-kratno 

delitvijo lic. Končni izgled za našo vesoljsko ladjo je 

prikazan v sliki desno.  
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Primer 2: Ligenj 

Modeliranje s poligoni se velikokrat uporablja tudi pri modeliranju organskih stvari, saj ima 

uporabnik kontrolo kako se bodo oblike prilagajale drugim stvarem, kje bodo bolj in kje manj 

podrobne ter kakšne podobnosti bomo dodali. 

Manipulacija posameznih komponent 
Kot smo pokazali že na primeru krivulj in ploskev je mogoče tudi v primeru uporabe poligonske 

mreže urejati zgolj posamezne komponente geometrije. Tako lahko z orodji za pomikanje, rotacijo 

in skalacijo manipuliramo posamezno ali množico izbranih komponent v posameznem načinu 

prikaza. 

Izbira prikaza komponent 
Ko z desnim miškinim gumbom kliknemo na objekt se pokaže meni z 

možnostmi prikaza različnih komponent objekta. Za nas so trenutno 

zanimive: Vertex (vozlišča), Edge (robovi), Face (lica), Vertex Face 

(vozlišča in robovi) in Multi (vse tri vrste komponent). 

Na tašen način lahko z uporabo orodij za izbiranje označimo tiste 

komponente našega objekta, ki jih dejansko želimo urejati. 

Dodajanje zanke robov 
Zelo dobrodošlo orodje pri modeliranju je tudi orodje za dodajanje zanke 

robov (angl. Insert Edge Loop). Orodje je dostopno v meniju Mesh 

Tools->Insert Edge Loop. To orodje nam omogoča, da na želenem mestu 

na obstoječem robu dodamo novo zanko robov, ki so povezani v eni 

smeri okoli celotnega objekta (če je to le mogoče) kot je na primeru 

kocke prikazano na sliki desno. 
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Izdelava lignja 
Izdelavo lignja pričnemo z enostavnim stožcem. V meniju 

izberemo Create->Polygon Primitives->Cylinder □ kjer 

spremenimo število osnih delitev (angl. Axis divisions) na 

16 in spremenimo os vzdolž katere bomo ustvarili stožec na 

X ter kliknemo na gumb Create. 

Preklopimo na način podrobnega prikaza s tipko [3]. Z dodajanjem novih zank robov in 

enakomernim povečevanjem/pomanjševanjem celotnih zank robov v zgornjem in stranskem pogledu 

dodelamo želeno obliko. 

   

                             Zgornji pogled                                     Stranski pogled 

Dodamo še nekaj zank robov in premaknemo ustrezna vozlišča in s tem oblikujemo tudi glavo 

lignja. 

 

Nadaljujemo z izdelavo lovk. Lignji imajo 8 lovk, od tega 6 krajših in 2 daljši. Za izdelavo lovk 

bomo večkrat uporabili orodje za izvlek. Najprej izberemo 6 lic za izvlek krajših lovk, kjer nato z 

izvlekom, skalacijo in rotacijo pridomo do približno želenega rezultata. Postopek ponovimo za 

izdelavo dveh daljših lovk. 

   

Daljši lovki nekoliko dodelamo, da dobita na koncu značilno razširjen del. Z urejanjem vozlišč na 

sprednjem delu dodamo plavuti. Z izvlekom dodajmo še značilne čeljusi. 
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Kar še preostane je, da dodamo oči. Prostora za dodajanje podrobnosti je še ogromno. 

 

Primer 3: LEGO možic 

Pri izdelavi 3D modelov si vedno pomagamo z referencami. Reference so lahko fotografije, slike, 

skice ali kar objekti, ki jih želimo zmodelirati. Velikokrat si lahko pomagamo tudi s slikami zajetimi 

iz točno določenih pogledov (npr. od spredaj, od strani, od zgoraj ipd.). Takšne slike si lahko kot 

pomoč za uporabo vstavimo tudi v samo sceno. 

Uporaba referenčnih slik v sceni 
Maya ponuja zelo preprost uvoz  referenčnih slik v samo sceno, vezanih na konkreten pogled. 

Najbolj elegantno to dosežemo, če imamo natančno poravnane slike iz različnih pogledov enakih 

dimenzij in resolucije. 

V pogledu kjer želimo dodati referenčno sliko 

kliknemo na gumb  v orodni vrstici okna pogleda. 

Odpre se nam okno za izbiro datoteke, kjer poiščemo 

ustrezno datoteko s sliko jo izberemo in izbiro 

potrdimo. V naši sceni se pojavi ploskev poravnana z 

izbranim pogledom, ki prikazuje izbrano sliko. V 

primeru, da želimo uporabiti več referenčnih slik v 

različnih pogledih, postopek ponovimo za vsak 

pogled. 

Če referenčne slike niso poravnane ali enako velike, 

lahko to dosežemo tudi v Mayi s tem, da 

premikamo, povečujemo/pomanjšujemo ploskve z 

referenčnimi slikami. V sliki desno je prikazana 

uporaba dveh referenčnih slik (za stranski in sprednji 

pogled).  
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LEGO možic 
Na podlagi predstavljenih tehnik izdelajte LEGO možica kot je prikazan na spodnjih slikah. 
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Lekcija 04 

Maya – Napredno modeliranje 
 

Povzetek 

19. Združevanje geometrije 

20. Urejanje geometrije 

21. Deformerji 

22. Live geometry 

 

Predmeti realnega sveta so velikokrat sestavljeni iz preprostejših osnovnih oblik ali pa vsaj deli 

predmetov povzemajo bolj osnovne oblike. Tako si lahko tudi pri modeliranju pomagamo s tem, da 

pri izdelavi kompleksnejših oblik združujemo preprostejše oblike. Tako lahko uporabimo različna 

orodja za združevanje geometrije. 

Orodja za združevanje geometrije 

Boolove operacije 
Boolove opreacije ste najverjetneje spoznali že pri osnovah logike (unija, presek, razlika) in se kot 

takšne pojavljajo tudi pri 3D modeliranju. V Mayi so nam dostopne v meniju Mesh→Booleans, kjer 

najdemo: unijo (angl. union), razliko (angl. difference) in presek (angl. intersection). Na takšen 

način lahko dve (ali več oblik) združimo kot prikazuje spodnja slika: 

     

       Originalna objekta              Unija              Kvader brez sfere       Sfera brez kvadra             Presek 

Pri razliki je rezultat odvisen od tega od katerega objekta odštevamo druge objekte (kar je odvisno 

od vrstnega reda označevanja). Pri tem lahko opazimo, da gostota mreže geometrije povzame 

gostoto posameznih objektov, kar lahko občasno povzroča preglavice. Še posebej kadar želimo diseči 

prav specifično obliko objektov. 

Združevanje mrežne geometrije 
Medsebojno pa lahko združimo tudi mrežno geometrijo brez posegov v sam 

sestav. Tako lahko z uporabo orodja za združevanje (angl. combine). 

Orodje je dostopno iz menija Mesh→Combine. Kot rezultat pa dobimo eno 

geometrijo, ki združuje mrežne predstavitve vseh združenih objektov kot 

prikazuje slika na desni za zgornji primer. Na takšen način lahko potem 
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sami združujemo (ali pa ne) posamezne mrežne primitive in jih med seboj povezujemo. 

Razdiranje geometrije 
Če imamo v eni geometriji med seboj nepovezane dele mreže jih je občasno smiselno razdružiti oz. 

razdreti v posamezne ločene objekte. To lahko dosežemo z uporabo orodja razdruži dostopnega v 

meniju Mesh→Separate. Podobno lahko dosežemo tudi z orodjem za odcep dela geometrije (angl. 

detach) dostopnega v meniju Edit Mesh→Detach. To orodje nam izbrani del geometrije odcepi od 

preostalega ne pa tudi loči v drug objekt. 

Urejanje geometrije 

Že v prejšnjem delu smo spoznali nekaj osnovnih orodij za urejanje geometrije, na tem mestu pa 

bomo predstavili še nekaj orodij, ki nam pogosto pridejo prav. 

Odsekaj 
Odsek (angl. Chamfer) je orodje, ki nam odseka oglišče in 

ga nadomesti z novimi oglišči pomaknjenimi vzdolž 

povezanih robov. Delovanje je prikazano v sliki desno. 

Združevanje oglišč 
V Mayi nam je na voljo tudi nekaj orodij za združevanje oglišč. Najbolj pogosto uporabljamo: 

- združi (angl. merge), dostopnega v meniju Edit Mesh→Merge, ki združi izbrana oglišča, ki 

so bljiže od predpisanega pragu. Prag določimo v nastavitvah ordoja. 

- združi v središče (angl. merge to center), dostopnega v meniju Edit Mesh→Merge to Center, 

ki združi izbrana vozlišča v njihovo težišče. 

- izniči (angl. collapse), dostopnega v meniju Edit Mesh→Collapse, ki nam označene robove 

ali lica izniči v vozlišče. 

Deformerji 

Z deformerji (angl. deformers) lahko preoblikujemo 3D geometrijo v skladu z matematično 

nefiniranimi deformacijami. Deformerji so dostopni v meniju Deform→Nonlinear in omogočajo: 

krivljenje/upogibanje (angl. Bend), razpihovanje (angl. Flare), sinusno deformacijo (angl. Sine), 

mečkanje (angl. Squash), zvijanje (angl. Twist) in valovanje (angl. Wave). 

Deformerji so zgolj modofikacije nad objekti in zato njihovo delovanej mrežne geometrije ne 

spremeni nepovratno. Zaradi tega je tudi pomembno, da v kolikor želimo njihovo funkcijo ohraniti 

pazimo kako transformiramo geometrijo. 

Brisanje zgodivine geometrije 

Če smo dokončno prepričani, da ne želimo več urejati lastnosti geometrije na podlagi začetnih 

atributov in/ali deformerjev, je smiselno objektom pobrisati zgodovino. S tem zapečemo obliko 

geometrije in jo naredimo neodvisno od začetnih paratmetrov (npr. število sekcij v valju ipd.). 

To storimo tako, da objetk izberemo, nato pa v meniju izberemo Edit→Delete by  Type→History. 
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Primer 1: Šalca 

Z zgolj zgoraj predstavljenimi orodji lahko tako iz dveh valjev zelo preprosto ustvarimo šalco kot je 

prikazana v spodnji sliki: 

- en valj uporabimo za izdelavo glavnega dela, kjer z dodajanjem zank robov povečamo 

želeno natančnost oblike in s premikanjem in skalacijo oglišč dosežemo želeno obliko 

glavnega dela; 

- drugi valj uporabimo za izdelavo ročaja. 

- Valj ukrivimo, mu pobrišemo kape in ga približamo glavnemu delu. 

- Valja združimo s funkcijo combine. 

- S funkcijo chamfer na ustreznih mestih dodamo potrebno število oglišč za spojitev mrež na 

obeh koncih ročajev. 

- S funkcijo merge to center združimo ustrezne pare vozlišč in s tem povežemo oba dela 

geometrije. 

 

Primer 2: Roka 

Z istimo orodji lahko modeliramo tudi bolj organske modele, kot je na primer roka. V večini smo 

uporabili orodja extrude, insert edge loop, combine, merge to center. Začnemo s škatlo nato 

izdelamo en prst, ga namnožimo. Posamezni prst prilagodimo in vse prste pričvrstimo na dlan. 

Proces je prikazan v spodnji sliki. 
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Primer 3: Goska 

Velikokrat si pri modeliranju pomagamo tudi s približnimi modeli, ki nam predstavljajo približno 

obliko našega končnega modela. Takšno pomožno ogrodje si lahko ustvarimo tudi sami z uporabo 

osnovnih primitivov. 

V našem primeru smo osnovno obliko glave goske upodobili z nekaj sferami, ki smo jim prilagodili 

velikost in jih raztegnili/skrčili vzdolž posamezne osi, da se prilegajo pomožnim skicam. Manjše 

objekte kot uporabimo, bolj natančno ogrodje si lahko vzpostavimo. 

Nadalje smo te sfere združili v eno geometrijo z uporabo orodja combine. Nato pa smo 

novonastalemu objektu pobrisali zgodovino in ga uporabili za živo ogrodje (angl. live geometry)  

V tem načinu se nam miška pri ustvarjanju nove geometrije samodejno lepi na živi objekt in lahko 

tako na njegovi površini ustvarjamo nova lica. Nova lica ustvarjamo z orodjem Mesh 

Tools→Create Polygon. Pri tem je najbolje ustvarjati štirikotnike in trikotnike. Paziti moramo, da 

jih ustvarjamo v nasprotni smeri urinega kazalca, saj so sicer lica obrnjena narobe. 

Lica ustvarjamo enega poleg drugega. Ko smo jih ustvarili želeno količino jih združimo z orodjem 

combine, jim pobrišemo zgodovino, nato pa jih v ustreznih ogliščih povežemo z uporabo orodij 

merge in merge to center. 

Dokončno obliko dobimo tako, da to mrežo podrobno prilagodimo skicam in po potrebi dodajamo/ 

odvzemamo nova vozlišča. 
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Lekcija 05 

Maya – Upodabljanje 
 

Povzetek 

23. Materiali 

24. Teksture 

25. Luči 

26. Kamera 

27. Upodabljanje 

28. Lepotni popravki 

 

Postopku izračuna slike, ki prikazuje našo 3D sceno pravimo upodabljanje. Za to, da lahko takšno 

sliko izračunamo pa moramo v naši sceni posameznim objektom prirediti materiale, v sceno 

postaviti luči, ki bodo objekte osvetljevale, pripraviti kamero, ki bo definirala pogled v sceno, 

določiti morebitne posebne efekte in na koncu sprožiti upodobitev. 

Materiali 

Izgled objektov v sceni je najbolj odvisen od tega iz kakšnega materiala je objekt. V Mayi imamo 

na voljo zbirko vnaprej pripravljenih materialov, ki jih lahko uporabimo in jih prilagodimo našim 

potrebam. Materiali se med seboj razlikujejo po načinu odboja svetlobe. Najbolj osnovni med njimi 

so: 

• Lambertov material, ki se uporablja za matirane površine (nepolirane površine, kreda ipd.), 

• Blinnov material, ki je primeren za kovinske površine, in 

• Phongov material, ki je primeren za steklene in polirane plastične površine. 

Poleg osnovnih materialov so nam v Mayi (z dodatkom Arnold) na razpolago še številni drugi 

materiali. 

Vključitev materiala v sceno 
Material vključimo v sceno z uporabo okna Hypershade, ki ga odpremo v meniju z izbiro 

Windows→Rendering Editors→Hypershade. Hypershade je prostor, kjer delamo z materiali in 

teksturami, lučmi, kamerami ter drugimi elementi, ki vplivajo na upodabljanje. Izgled okna je 

prikazan v spodnji sliki in zajema: seznam materialov in pomožnih struktur (spodaj levo), seznam 

že ustvarjenih materialov (zgoraj), Lastnosti izbranega materiala/pomožne strukture (desno), in 

delovno površino za povezovanje materialov in pomožnih struktur (v sredini). 
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Nov material ustvarimo tako, da iz levega seznama izberemo osnovo. S tem v sceni ustvarimo nov 

material, ki ga bomo lahko prirejali objektom, hkrati pa se nam ta material in njegova sestava 

prikaže v osrednjem oknu. Material priredimo objektu v sceni tako, da ga nanj iz zgornjega 

seznama v oknu Hypershade povlečemo s srednjim miškinim gumbom. 

Predelava materiala 
Material lahko predelamo tako, da v desnem delu okna 

(Attribure editor) Hypershade spremenimo ustrezne lastnosti 

(barva, prosojnost ipd.). Število lastnosti materiala je odvisno od 

vrste izbranega materiala in se lahko razlikuje od nekaj preprosti 

parametrov (v primeru materiala tipa Lamberd), do množice 

različnih parametrov (v primeru materialov priloženih 

upodobljevalniku Arnold), kar 

je prikazano tudi v slikah na 

levi, kjer so desno lastnosti 

Mayinega materiala Lambert, 

desno pa Arnoldovega mateirala 

aiStandardSurface. Arnoldov 

material vsebuje veliko vnaprej 

pripravljenih nastavitev, do 

katerih lahko dostopamo preko 

gumba Presets. 

Najpomembnejši skupni atributi, ki določajo lastnosti materialov so: 

• Color – določa osnovno barvo materiala. Z levim klikom na barvno polje odpremo okno za 

izbiro barve. Z drsnikom pa lahko spreminjamo svetlost izbrane barve. 
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• Transparency – določa prozornost materiala. Z drsnikom spreminjamo intenzivnost 

prozornosti. S spremembo barvnega polja pa lahko spremenimo privzeto belo prozornost 

(material je prozoren za vse barve) na barvno prozornost (material je prozoren za izbrano 

barvo). 

• Ambient Color – določa ambientalno barvo, ki je prisotna tudi brez zunanje osvetlitve. 

• Incandescence – določa barvo in jakost svetlobe, ki jo material seva (pri tem ne osvetljuje 

drugih predmetov) 

• Diffuse – določa kako močno material razprši svetlobo. 

• Specular Color – določa barvo zrcalnega odseva. 

• Reflectivity – določa odsevnost materiala. 

• Reflected color – določa barvo odseva. 

Dodelitev materiala objektu 
Če želimo, da ima nek predmet pri upodabljanju lastnosti nekega materiala, mu moramo dodeliti 

želeni material. To storimo tako, da v Hypershade panelu s srednjim gumbom na miški kliknemo 

na želeni material in ga povlečemo do predmeta. Druga možnost pa je, da označimo predmet (ali 

več predmetov), nato v hypershade panelu z desnim klikom na miško nad želenim materialom 

odpremo kontekstni menu in izberemo opcijo Assign Material to Selection. Tretja opcija je, da v 

sceni na objekt kliknemo z [DMG] in iz menija izberemo Assign Existing Material, nato pa 

izberemo želen material. 

Teksture 

Teksture dodajo homogenim osnovnim materialom vzorce. Vzorci lahko temeljijo na barvi ali na 

katerem drugem atributu materiala (transparentnost ...). 

Postopek izdelave enostavne teksture je sledeč: 

1. V prizor vključi in po potrebi predelaj material, na katerega bomo nalepili teksturo. 

2. V levem delu Hypershade panela znotraj razdelka Create (v mapi Textures) s srednjim 

gumbom na miški kliknemo na želeno teksturo in jo povlečemo na material na katerega 

bomo nalepili teksturo (material je viden na delovni površini v desnem delu Hypershade 

panela). Ko teksturo spustimo na material moramo določiti kateri atribut materiala (barva, 

prozornost ...) bo povezan s teksturo. 

3. V urejevalniku atributov predelamo teksturo po naših zahtevah. 

Luči 

Podobno kot je to v resničnem svetu, so luči v Mayi potrebne za osvetlitev prizora. Maya pozna 

nekaj osnovnih vrst luči, ki jih lahko uporabimo pri našem delu. Osnovne vrste luči so: 

          

• Ambient Light – seva na dva načina: nekaj svetlobe seva enakomerno v vse smeri iz položaja 

luči v prostoru, nekaj svetlobe pa seva v vse smeri iz vseh smeri. 

• Directional Light – seva enakomerno le v eni smeri, tako da so žarki med seboj vzporedni, 

kakor pri zelo oddaljenem izvoru svetlobe (na primer svetloba sonca). 

• Point Light – seva enakomerno v vse smeri iz položaja luči v prostoru (na primer svetloba 

sveče). 



  

37 | FRI |  3D modeliranje z orodjem Autodesk Maya 

• Spot Light – seva enakomerno v omejene smeri (stožec) iz položaja luči v prostoru (na 

primer svetloba žarometa). 

Vključitev luči v prostor 
Luč dodamo prizoru s pomočjo Hypershade-a (podobno kot smo v prizor vključili materiale). S tem 

ko v prizor vključimo luč, se ta postavi na privzeto mesto (center) v prostoru (ter orientira v 

privzeto smer). Luč je potrebno nato še premakniti na želeno mesto ter jo v primeru usmerjene luči 

še orientirati v želeno smer. Za to uporabimo že znana orodja za premik in orientacijo ali 

manipulator za luč. 

Predelava luči 
Potem, ko smo neko luč dodali v prizor, jo še predelamo v skladu z našimi potrebami. Luč 

predelamo tako, da spremenimo ustrezne atribute, ki ga določajo (podobno kot pri materialu) z 

uporabo urejevalnika atributov. 

Najpomembnejši skupni atributi, ki določajo lastnosti luči so: 

• Color – določa barvo svetlobe. 

• Intensity – določa jakost svetlobe (lahko je tudi negativna => luč odstranjuje svetlobo). 

Izdelava slike 

Izdelava slike je zadnja faza pri upodabljanju. Na podlagi postavitve modela, materialov, tekstur, 

luči, kamer in posebnih efektov v prizoru se izdela (izračuna) slika ali več slik prizora. Preden 

pričnemo z izdelavo slike lahko spremenimo privzete nastavitve parametrov pri izdelavi slike 

(resolucija, kvaliteta, ...). Parametre izdelave slike pregledujemo in nastavljamo v oknu 

Windows→Render Settings. Uporabljamo ga za pregled in nastavitev parametrov, ki določajo 

izdelavo (izračun) slike. Okno vsebuje veliko množico parametrov, kot so ime slke, format slike, 

resolucija, kvaliteta slike in druge, ki jih lahko spremenimo in s tem vplivamo na izračun slike. 

Nekaj pomembnih parametrov pri izračunu slike: 

• Image File Output → Camera – določa aktivno kamero za sliko. 

• Resolution → Width – določa širino slike. 

• Resolution → Height – določa višino slike. 

• Raytracing Quality → Raytracing – vključi način izračuna s sledenjem žarka. 

Sliko lahko izdelamo in si jo ogledamo v oknu Windows→Render View. 

Render View 
Uporabljamo ga za izdelavo in ogled izdelanih slik. Slika bo izdelana skladno s trenutnimi 

nastavitvami upodabljanja. Proces izdelave slike sprožimo s klikom na . Izdelamo lahko le del 

slike, tako, da najprej z miško v Render View oknu označimo del, ki nas zanima, in nato s klikom 

na sprožimo proces izdelave slike. Izven dela, ki smo ga označili ostane prejšnja slika nespremenjena 

(koristno za primerjavo). 

Privzeta kamera pri izdelavi slike je tista, ki ustreza perspektivnemu pogledu na prizor. 
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Lekcija 06 

Maya – Animacija 
 

Povzetek 

29. Ključni okvirji 

30. Animacijske krivulje 

31. Animacija s pomočjo deformerjev 

32. Animacija s pomočjo omejitev 

 

Animiranje je postopek pri katerem manipuliramo/preoblikujemo/premikamo objekte in s tem 

dosežemo občutek, da se le-ti premikajo. Animacija izvira iz 19. stoletja in se od takrat nenehno 

razvija. 3D animacija ima svoj začetek v 1940-ih, od 1970-ih dalje pa se redno pojavlja kot 

pomembni del filmske industrije. Od takrat pa se je animacija pojavlja v različnih okoljih za 

najrazličnejše namene. 

Osnove 

Ključni okvirji 
Animacija z uporabo ključnih okvirjev poteka tako, da predmet v želenih časovnih mestih 

postavimo/preoblikujemo v želen položaj. Med takšnimi položaji lahko potem animacijska ogrodja 

sama ustvarijo animacijo, ki jo lahko nato dodatno popravimo z uporabo animacijskih krivulj. 

Ključni okvir določa (fiksira) vrednosti izbranih atributov v nekem časovnem trenutku. Vrednosti 

atributov na intervalih brez ključnih okvirjec se izračunajo avtomatsko. Ključni okvir postavimo v 

oknu z lastnostmi na desni strani zaslona ali v meniju Animate→Set Key (pri tem se vam na 

časovnem traku na dnu zaslona izrišejo rdeče črtice za vsako postavljeno ključno točko). Bljižnica 

na tipkovnici je tipka [S]. 

Animacijske ključne okvirje lahko postavljate za skoraj vse atribute predmetov (ne le za pozicijo, 

rotacijo in spreminjanje velikosti). Če na ime nekega parametra (npr. barvo material  - Color) 

kliknete z desnim gumbom, lahko v menuju izberete Set key in tako postavite ključni okvir za ta 

parameter. 



  

39 | FRI |  3D modeliranje z orodjem Autodesk Maya 

Časovni trak 

Na dnu Mayinega okna se nahaja časovni trak, ki kaže dolžino animacije (v sličicah) ter kje se v 

animacije nahajate. Z vpisom vrednosti v vnosni okni levo in desno pod časovnim trakom lahko 

poljubno podaljšate oz. skrajšate dolžino animacije. 

S klikom na trak se lahko premaknete na določeno sličico animacije; če pritisnete na trak z levim 

mišjim gumbom, se bodo vsi animirani parametri ponovno izračunali ter postavili na prave 

vrednosti, če pa na trak pritisnete s srednjim gumbom, animirani parametri ne bodo dobili novih 

vrednosti. 

 

 

Animacijske krivulje 

Na podlagi postavljenih ključnih okvirjev, Maya izračuna animacijske krivulje za animirane 

atribute. Te krivulje je mogoče popravljati v urejevalniku Graph Editor (Window→Animation 

Editors→Graph Editor). Ključne okvirje in tangente izbiramo z levim gumbom miške, premikamo 

pa jih z srednjim gumbom miške. 

Primer 1: Poskakajoča žogica 

Osnove animacije bomo spozali na primeru 

poskakajoče žoge. Najprej bomo žogico animirali na 

mestu kot je to prikazano v skici desno. Da dosežemo 

takšno animacijo, je potrebno uporabiti zgolj osnovna 

transformacijska orodja (premik in skalacijo).  

Začnemo čisto pri vrhu, kjer postavimo prvi ključni 

okvir, nato se pomaknemo na časovnici na mesto, kjer 

želimo, da se žoga dotakne tal. Izvedemo potrebne transformacije (žogico premaknemo do podlage 

in jo delno sploščimo). Dodamo ključni okvir. Ponovimo isto za nižji odboj. Poleg sploščitve ob 

trku lahko dodamo še raztez žogice ob pospeševanju. 

V drugi vaji dodamo še pomik vzdolž 

vodoravne osi, kar nakazuje skica desno.  

Pri postavljanju ključnih okvirjev seveda 

velja, da jih lahko kasneje popravimo in 

tako spremenimo celotno animacijo ali 

zgolj del s katerim nismo zadovoljni. 

Prav tako lahko za popravljanje 

določenih lastnosti animacije uporabimo 

urejevalnik krivulj, kjer lahko zelo 

precizno nastavimo lastnosti posameznih 

spremeb v času. 
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Primer 2: Plavajoča riba 

Bolj napredne tehnike animacije z Mayo bomo spoznali na primeru plavajoče ribe. Za cilj naj nam 

bo izdelava animacije v kateri se preprosta riba z gibi poganja skozi vodo. Pri tem naj ji sledi 

kamera. 

Izdelava ribe 
Preden se od bližje spoznamo z bolj naprednimi koncepti animacije, si v zgradimo 3D model 

preproste ribe, ki nam bo služila kot osnova za delo z deformatorji in omejitvami. 

Kot riba nam bo služila krogla, katere obliko bomo spremenili. Spremembo krogle v ribo bomo 

izvedli z neposredno transformacijo kontrolnih točk, ki so osnova krogle (ta način se razlikuje od 

spreminjanja oblike telesa z uporabo deformatorjev, s katerimi transformiramo kontrolne točke 

telesa le posredno). 

Ribo v vodoravnem položaju bomo veliko lažje oblikovali, če bo imela krogla polarno os v 

vodoravnem položaju. Ker je privzeta orientacija te osi navpična, moramo spremeniti ustrezni 

parameter za izgradnjo krogle. Kroglo postavimo na prizorišče z 

menujsko izbiro Create→Polygon Primitives→Sphere □. 

Orientacijo polarne osi krogle spremenimo s spremembo 

parametra Axis. Njegovo vrednost nastavimo na X. Nekoliko si 

olajšamo oblikovanje tudi z povečanjem števila kontrolnih točk. 

To dosežemo s povečanjem števila višinskih in rotacijskih 

razdelitev sfere. V našem primeri ju povečamo na "axis division 

= 10" in "height division=10". 

Kroglo preoblikujemo v ribo z neposredno transformacijo oglišč 

kot je prikazano na sliki desno. 

Animacija plavalnih gibov z deformejem 
Realistično animacijo plavalnih gibov ribe z neposredno transformacijo kontrolnih točk ribinega 

telesa bi dosegli zelo težko. V ta namen raje uporabimo enega izmed deformatorjev, ki nam jih nudi 

Maya. Deformatorji omogočajo enostavno in celovito spreminjanje oblike poljubnih predmetov. 

Z deformatorji lahko spreminjamo obliko poljubnega predmeta, katerega struktura je definirana s 

kontrolnimi točkami. To so NURBS krivulje, NURBS ploskve, poligonske ploskve in mreže 

(lattices). Maya vsebuje več vrst deformatorjev. Nekateri izmed njih so na primer: 

• Lattice: omogoča proste deformacije na podlagi deformacijske mreže na predmetu; 

• Cluster: omogoča transformacijo kontrolnih točk z različnim vplivom; 

• Nelinearni deformatorji: omogočajo upogibanje, zvijanje, 

valovanje, ... predmetov; 

Uporaba sinusnega deformerja 
Najprej označimo predmet, ki ga želimo deformirati (v našem 

primeru je to riba) . Nato ustvarimo nelinearni sinusni 

deformator z menujsko izbiro "Deform|Create Nonlinear|Sine". 

Z izbiro vhodnega vozlišča "sine1" v oknu "Channel Box" lahko 

interaktivno dostopamo do parametrov našega deformatorja. 
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Ker je parameter, ki določa amplitudo sinusne krivulje enak 0, ga 

nastavimo na neko od 0 različno vrednost (na primer 

"Amplitude=0.3"). 

Animacija deformerja 
Naslednji korak je animacija deformatorja. S tem dosežemo, da se 

bo ukrivljenost ribe, ki je posledica vpliva sinusnega deformatorja, 

spreminjala s časom. Parameter sinusnega deformatorja, ki ga je v 

našem primeru potrebno spreminjati s časom je parameter Offset. 

Posledično se bo spreminjal vpliv deformatorja in zato tudi oblika 

ribe. ̧ 

V časovnem oknu se postavimo na sličico 0 (najverjetneje se tam že nahajamo). V oknu Attribute 

Editor nastavimo vrednost parametra Offset = 0 ter za ta parameter postavimo ključni okvir. Nato 

se v časovnem oknu postavimo na eno od poznejših sličic (na primer na sličico 39) spremenimo 

vrednost parametra Offset = -2 ter za ta parameter spet postavimo ključni okvir. Smiselno je, da je 

absolutna vrednost parametra Offset v drugem primeru enaka parametru Wavelength, saj se tako 

ukrivljenost ribe povrne v začetni položaj. 

Na tej točki naša animacija obsega en poln zamah ribe (sličice 0 do 39), preostanek pa je riba 

negibna. Gibanje v preostanku animacije ustvarimo s periodičnim ponavljanjem že definirane 

animacije parametra Offset. To lahko dosežemo z urejevalnikom grafov, ki ga odpremo z menujsko 

izbiro Window→Animation Editors→Graph Editor. Ta nam prikazuje animacijske krivulje za 

parametre, ki smo jih animirali. V našem primeru 

vidimo krivuljo, ki določa vrednost parametra 

Offset v odvisnost od številke sličice (torej v 

odvisnosti od časa). 

Periodično ponavljanje dosežemo tako, da izberemo 

želeno krivuljo ter preko menuja izberemo 

Curves→Post Infinity→Cycle. S tem se bo 

sprememba izbranega parametra v animaciji 

ponavljala v neskončnost. 

Animacija po poti premikanja 
Eden zadnjih korakov k uresničitvi naše zamisli je animacija premikanja cele ribe po neki poti sem 

ter tja. To storimo tako, da ustvarimo krivuljo, ki predstavlja želeno pot, ter na to krivuljo 

pripnemo ribo. Riba se bo nato v času naše animacije premaknila po krivulji od njenega začetka do 

njenega konca. Pri tovrstni animaciji se nam ni potrebno ukvarjati s neposrednim postavljanjem 

ključnih točk. 

Najprej ustvarimo krivuljo, ki predstavlja pot. To storimo z orodjem za krivulje, ki ga dobimo z 

menujsko izbiro Create→EP Curve Tool. Naknadno lahko krivuljo še popravimo z transformacijo 

kontrolnih točk. 

Nato je potrebno ribo pripeti na krivuljo poti. Pravzaprav je potrebno skupaj z ribo pripeti tudi 

sinusni deformator, da bi lahko obdržal vpliv in periodično ukrivljal ribo. Zato je najbolje, če ribo 

in deformator najprej grupiramo (označimo ribo in deformator ter v menuju izberemo 

Edit→Group). Sedaj tako narejeno grupo pripnemo na krivuljo tako da najprej izberemo grupo 

nato krivuljo in v menuju izberemo Animate→Paths→Attach to Path. Če sedaj zaženemo animacijo 

opazimo, da se cela riba giba po definirani poti premikanja ter se istočasno upogiba skladno z 

sinusnim deformatorjem. Potrebno pa je popraviti orientacijo ribe tako, da bo vedno usmerjena z 
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glavo v smeri trenutnega premikanja. To lahko napravimo tako, da z urejevalnikom atributov 

vozlišču motionPath1 spremenimo parametre Follow = on, Front Axis = Z, Up Axis = Y in Inverse 

Front = On. 

Sledenje kamere s pomočjo omejitev 
Tudi sledenje kamere premikajoči ribi, lahko zelo poenostavimo. V ta namen lahko uporabimo 

omejitve s katerimi dosežemo, da atributi enega predmeta (na primer položaj) vplivajo na atribute 

drugega (na primer orientacija) – položaj, orientacijo ... omejimo z drugim predmetom. 

Maya pozna mnogo vrst omejitev. Med njimi so na primer: 

• omejitev položaja (angl. Point Constraint), ki omeji položaj enega predmeta z položajem 

enega ali več drugih; 

• omejitev usmerjenosti (angl. Aim Constraint), ki omeji orientacijo predmeta tako da je 

vedno usmerjen proti ostalim; 

• omejitev orientacije (angl. Orient Constraint), ki omeji orientacijo enega predmeta z 

orientacijo enega ali več drugih; 

Premikajoči ribi bomo sledili z novo kamero, ki jo ustvarimo z menujsko izbiro 

Create→Cameras→Camera. Ta kamera ne bo statična, temveč bo s smerjo telesa sledila 

premikanju ribe po njeni poti. Uporabili bomo omejitev usmerjenosti. 

Omejitev usmerjenosti dosežemo tako, da izberemo skupino z ribo in deformatorjem ter nato še 

kamero (zadnjega mora biti izbran tisti predmet, ki bo omejen). Ko imamo tako izbrane predmete 

ustvarimo omejitev z menujsko izbiro Constrain→Aim. Na koncu je potrebno še popraviti 

orientacijo kamere. To storimo tako, da v vozlišču, ki predstavlja omejitev kamere (verjetno se 

imenuje camera1_aimConstraint1 z urejevalnikom atributov popravimo parameter Aim Vector na 

(0,0,-1). 
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Lekcija 07 

Maya – Uvoz objektov v Mayo 
 

Maya podpira širok nabor 3D formatov, ki jih lahko uvozimo. Največji nabor formatov nam je na 

voljo na sistemu Windows, drugod je nabor formatov precej omejen. 

Za prenos iz okolja SolidWorks lahko uporabimo format IGES ali STL. Podorobnosti za izvoz 

mdelov v IGES formatu iz okolja SolidWorks najdete v originalni skripti za predmet RPO I. 

Če izvoženih modelov ne boste morali odpreti v Mayi potem pri izvozu v format IGES izključite 

opcijo Export 3D Curve features. 

3D modeli v Mayi dobo predstavljeni ali z mrežno geometrijo ali s površinami. Delo z njimi je 

enako kot smo ga že spoznali. 

 


