
3D modeling using Autodesk Maya 

 
Ciril Bohak 

- 2021 -  



  

 

 

2 | FRI |  3D modeling using Autodesk Maya 

 

 

Lection 01 

M aya - Introduction 
 

Overview 

1. User interface 

2. Projects and files 

3. Scene views 

4. Objects and components 

5. Primitives 

6. Basic transformations and pivots 

User interface 

  

Default screen structure (see the figure above):  
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● M enu bar (bright red), contains menus through which we access tools and / or perform 

desired actions in modeling, rendering, animation, ... The first 6 menus do not change, the 

rest depend on the selected mode of operation, which is selected in the status bar; 

● Status bar (bright green), contains a set of shortcuts to commands and tools for object 

and component selection. In addition, you can select the mode of operation in the status 

bar and thus adjust the composition of menus and shelves; 

● Shelf (dark blue), provides quick and easy access to frequently used tools. The user can 

adjust the shelves to their own needs; 

● Toolbar (yellow), contains the basic tools and the last tool used. In addition, we can 

customize the look of the workspace in the toolbox; 

● Workspace (pink), is the central part of the user interface, which is intended primarily 

for viewing the scene. It can also display the various editors we use in our workflow; 

● Channels W indow (bright violet), provides access to object and node attributes. 

Attributes can be set in this window and linked to animation key frames; 

● Layers Pane (dark violet), layers allow objects to be grouped together, which can then 

be considered separately from the other layers. Individual layers can be hidden or even 

rendered separately; 

● Timeline (bright blue), allows you to move through the time dimension of the scene. On 

it we can define key frames or interactively watch an animated scene. You can use the 

command buttons to step through time, start playback, or set animation properties; 

● Command line (orange), you can run MEL or Python commands directly from the 

command line; 

● Help bar (dark green), shows quick help with working with the user interface, the state 

of execution of actions, errors and other information. 

Projects and files 

Projects 
In Maya, the work is project-based. It makes the most sense to create a separate project for each 

integrated case in which both the program settings files and all the necessary files for work will be 

stored. Create a new project in Maya by choosing File -> Project -> New. You must specify the 

project name and the directory in which you want to save all project files (eg Documents \ Maya). 

For individual file locations, it is best to select the Use Defaults option. When you have entered the 

project settings, press Accept. This determines where your files will be stored (scenes in the scenes 

subfolder, images in the images subfolder, etc.). It is recommended that folder names do not 

contain spaces or special characters. 
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If you are working on several projects, you can switch between them by selecting: 

File -> Project -> Set. 

If you have not defined a project, your files will be stored in the folder documents_folder \ maya 

\ projects \ default, where documents_folder is the system folder in which the documents of each 

system user are located. 

File typer in Maya 
Maya has some of its own file formats to store information about scenes, images, scripts. In 

addition to these, it also supports a wide range of other formats that can be used to share data 

with other applications. 

● M aya binary (.mb) the files contain a scene description in binary form. The description 

includes objects, textures, animations, and some other details; 

● M aya IFF (.iff) files are used to store rendered (bitmap) images. In addition to 

information about the colors of individual pixels, the file can also store information about 

depth, mask, or anything else; 

● Skripte M EL (.mel) are text files in which the commands of the Maya MEL language are 

written, with which we can supplement the functionalities offered by the user interface, and 

so e.g. we generatively generate certain objects, algorithmically define the execution of 

animations, etc. The same can be achieved with Python (.py) scripts. 

Scene views 

When modeling a scene, we mostly work in 3D space. Cameras with orthographic and perspective 

view offer us various possibilities of insight into the scene. 

Default scene views: 
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Changing the view (camera) 
The scene view can be adapted to the needs by changing the position and direction of the camera, 

which determines the selected view. 

• Rotation -  by pressing the [ALT] key and pressing the left mouse button [LMB], you can 

rotate the camera around the vertical and horizontal axes. 

• M ove (vertical and horizontal) – you can move the camera left / right and up / down 

by pressing the [ALT] button and pressing the middle mouse button [MMB]. 

• Zooming – by pressing the [ALT] key and pressing the right mouse button [RMB], the 

camera can be moved towards or away from the center of the scene. The same can be 

achieved by using the mouse wheel [MW]. 

Object display 
Individual objects can be displayed in the scene with varying accuracy. Use the [1], [2] and [3] keys 

to switch between different ways of displaying models, from the roughest to the most accurate 

(smoothed). 

We can also change the way the object is displayed / shaded. Use [4] - [7] keys to toggle between: 

       

4 – Wireframe 5 – Color view 6 – Texture view 7 – Lighting view 
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Objects and components 

The scene is made up of objects. Objects include: curves, surfaces, cameras, lights, deformations,… 

Objects consist of components such as checkpoints, polygons, gripping points and the like. Objects 

present in the scene can be viewed in the Outliner window (Window -> Outliner or select it in the 

toolbar). 

Manipulation mode 
In Maya, you can interact with objects in two ways: in object mode or in component mode: 

• Object mode -  where we work with objects as a whole: 

 
• Component mode - where the individual components of the object are also visible. 

Depending on the type of geometry, the object can consist of various components (control 

points, nodes / edges / surfaces, etc.). The figure shows the work with control points: 

 

 

Switch between modes by pressing the [F8] key, selecting one of the 

buttons in the status bar (where the first icon  represents working 

with objects and the second working with components), from the menu 

accessible by clicking with [LMB] on the object and selecting the 

appropriate components as shown in the figure to the right. 
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Attributes and nodes 

Attributes 
All properties of objects and components are stored as attributes. When we model, animate, or 

otherwise manipulate objects, we directly or indirectly change attributes. Attributes can be viewed 

or changed directly in the channel window or in the attribute editor ([CTRL + A] key). 

   

 

Nodes 
Nodes are the basic building blocks in Maya operation. Nodes are groups of related attributes that 

may be interconnected and / or interdependent. For example, the attributes that determine the 

transformation of an object are grouped in a transformation node. The basic types of nodes are: 

• Transform nodes – determine the position, orientation and magnification of objects; 

• Shape nodes – determine the position of individual components of the object; 

• Input nodes – determine how objects are constructed; 

• Shading nodes – determine the properties of materials for individual objects. 

Dependency graph 
It represents a collection of nodes that are interconnected. The dependency graph allows us to 

identify and connect individual nodes. This graph can be viewed in the Hypergraph window 

(Window -> Hypergraph). 

Primitives 

Primitives are prefabricated objects of commonly used shapes. Maya offers a range of basic objects 

that can be used as a basis for further shaping. These primitives are, for example: sphere, cube, 

cylinder, cone, plane, torus, circle, square (sqare),… Primitives can be of the NURBS type, 

Channel window Attribute editor 
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polygonal or volumetric. More or less than those listed are available for each type of primitive. 

Primitives can be created via menus: for NURBS primitives: Create-> NURBS Primitives->…, for 

polygon primitives: Create-> Polygon Primitives->…, and for volumetric primitives: Create-> 

Volume Primitives->… 

Before making a basic object, by selecting the square next the menu option, we can also determine 

its basic parameters, such as: size, accuracy, number of components, etc. 

Basic transformations and pivots  
Basic transformations include changing the position, orientation and size of an object / component 

in space. Basic transformations can be performed by directly changing the attributes (in the 

Channel Window or the Attribute Editor) or by using transformation tools. These tools are: 

• Move tool – shortcut is [W]  

 
• Rotate tool – shortcut is [E] 

 
 

• Scale tool – shortcut is [R] 
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Pivots 
Pivots are points in space that represent a reference point for performing transformations (e.g. a 

point around which an object rotates). The pickup can be edited by pressing the [Insert] key (or [d] 

on MacOS) when one of the basic transformation tools is selected. Once we have arranged the grip, 

we return to normal operation by pressing the same key again. 
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Lekcija 02 

M aya – M odeling with NURBS 
 

Overview 

7. NURBS curves 

8. NURBS surfaces 

9. Grouping objects 

10. Wirking with components 

11. Use of Revolve 

12. Use of Loft 

Example 1: Rocket 

As the first example of working with Maya, we will make a simple 

rocket. 

First we create a new scene: File-> New Scene or the shortcut [Ctrl + 

N] (on MacOS [Cmd + N]).  

A new window will appear, in the middle of which the spatial grid is 

displayed. The current view is perspective and allows us to view the 

scene and the objects in it from all sides. You can change the view by pressing the [Space] key, 

which shows us 4 views (front, side, top and perspective), return to the desired view by moving the 

mouse over it and pressing the space bar again. 

Rocket body 
We will first create the rocket body. The goal is 

to create a cylindrical body with a tip at the top 

and an opening at the bottom. 

We switch to the side view where we will create 

the silhouette of our rocket using curves. In the 

status bar, switch to Modeling mode and then 

select Create-> Curve Tools-> EP Curve Tool 

from the menu. 

Figure 1: Creating new scene. 

Figure 2: Create->Curve Tools->EP Curve Tool  
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With this tool, we can add points in the side view, and Maya will draw a fitting curve through 

them. We will create only one edge of the rocket body as seen from the side. 

Insert a few points so that you get a curve similar to the one in the picture. 

If necessary, switch to component editing mode [F8] and move each point 

to get the desired look. 

With such a curve, we can now create a revolved 

body by rotating the curve around the y-axis and 

thus forming the hull of our rocket. We do this by 

using the Revolve tool. Select the curve (let it be 

green), then select Surfaces-> Revolve via the 

menus. The result is a grid of curves, as shown in 

the figure to the right. If we switch back to 

perspective view we see that we have really 

created a 3D object. 

If we now highlight an object, its properties are displayed in the Channel 

Window, including the name in our case revolvedSurfaceShape1. Maya assigns a 

name to each newly created object. We can also change this name ourselves, 

which helps us later when we have a lot of items in the scene and we want to 

quickly find the one we want in the list. Let's rename our object rocketBody. 

Rocket engine 
In the next step, we will create the exhaust of the rocket engine. Similar to the 

construction of the body, we will use the revolve function here as well. The 

procedure is the same, and the goal is to get a rocket shape  similar to the one in 

the picture on the right. We also change the name of this object to rocketExhaust. 

We can now combine the body and exhaust of the rocket. Select the exhaust, 

press the [W] key to activate move tool and move it so that it connects to the 

rocket frame. The easiest way to move the exhaust is in the side view, as this is 

the best way to see when it is in the correct position. 

We can use the Channel Window to move objects more precisely, but if the 

accuracy of the grid is sufficient, we can turn on the use of the grid (snap to grid) 

with the button  in the status bar. This allows us to place points only on the 

grid. 

We can see that after the shift, the curve we used to make the exhaust is still 

visible, which is also shown in the picture on the right. In fact, there is also a 

curve in the scene that we used to make the body. We can delete both curves 

without any worries, as we no longer need them. This is done by selecting both 

curves (several objects can be marked at the same time by holding down the [Shift] key and 

clicking on all the desired objects) and deleting them using the [Delete] key. 
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If we make a mistake in our work or want to go back to the previous step, we can easily use the 

undo function. It is accessible via the Edit-> Undo menu or using the shortcut [Ctrl + Z] (on 

MacOS [Cmd + Z]) or just [Z]. You can also redo the canceled action with Edit-> Redo or. Use the 

[Ctrl + Shift + Z] shortcut or just [Shift + Z] to use the [Cmd] key instead of [Ctrl] on MacOS. 

Connecting objects into groups 
We will now connect the two components of the rocket into a group (we will group them). This 

means that both objects will be connected so that we can move them together, we can assign 

certain properties to them at once, and so on. 

First, mark both objects by clicking and holding [LMB] to the left above the rocket frame and 

dragging the lower part of the rocket exhaust to the right, or by clicking [LMB] on one object first, 

pressing and holding the [Shift] key, and then clicking with [LMB] to another subject. 

Now select Edit-> Group from the menu or press the [Ctrl + G] keys. We notice that the whole 

structure now turns green, which tells us that the object is highlighted, and a new name appears in 

the channel window, namely group1. We will also change this name to something more friendly, 

namely the rocketBase. 

If we now click somewhere outside the rocket and then click [LMB] again somewhere on the rocket, 

we would expect the rocketBase group to be selected, but this will not happen. If we click on 

rocketExhaust or rocketBody, only the component we clicked on will be selected, which is contrary 

to what we talked about in the groups. It is important to be aware that by linking an object into a 

group, individual objects from this group do not lose the opportunity to select them individually 

and assign them only their specific properties. 

Maya applies the principle of hierarchy, the group rocketBase is the parent of the objects 

rocketExhaust and rocketFrame, which are descendants of the group rocketBase. The objects of the 

rocketExhaust and rocketBody are siblings. 

When we have one of the siblings, we can access the parent by pressing the [Up] arrow, on the 

contrary, we can access the sons with the [Down] arrow. The siblings are accessed with the [Left] 

arrow or the [Right] arrow. 

Creating flaps 
The rocket flaps will be made with the help of flattened cones, which will be further reshaped. 

 First, we move the current model of the rocket from the coordinate 

starting point so that we can create one instance of the flap in it. From the 

menu, select Create-> NURBS Primitives-> Cone □ (click on the box 

when selecting). This allows us to define the basic properties of the cone. 

Define the properties: 

• Axis: Y 

• Radius: 1.5 

• Height: 3 



  

 

 

13 | FRI |  3D modeling using Autodesk Maya 

 

 

we press Apply. This created a cone with the desired properties in the 

coordinate origin. We rename it rocketFlap1. 

This, of course, is not yet a flap, as it should be slightly twisted, smaller and 

flattened. Rotate it 120º around the x-axis in the Channel Window. Then 

flatten it by scaling it in the same direction to 1/5 of the original value by 

entering the value 0.2 in the Channel Window under the ScaleX attribute. The 

flaps are slightly reduced in the y and z directions to a value of 0.75. 

The wing is moved into the rocket so that the cone shell partially extends from 

the rocket and the bottom is completely hidden as shown in the figure. 

We want to make 5 more flaps and distribute them evenly around the rocket's hull. We will do this 

by using the duplicate tool, which allows us to multiply the desired object as many times as we 

like. With additional settings, we can achieve a special behavior of the duplication function, which 

allows you to place duplicates in the desired places. 

Pivots 
Before we start duplicating objects, let's look at where the pivots of individual objects are located. 

As already mentioned, pivot points are reference points around which transformations operate. 

Duplicating flaps 
In order to make the flaps as elegant as possible with as little extra 

work as possible, we will multiply one flap we already have 5 times and 

rotate it 60º za around the center of the rocket each time. 

By default, the pivot of an individual object is at its center. In the case 

of a cone, this is in the center of the base area. So if we want to 

multiply the cone around the center of the rocket, we have to move its 

grip to the center of the rocket. This is done by moving to the view 

from above, pressing the [d] key to manipulate the grip and moving it 

as close as possible to the center of the rocket. For help, you can switch to grid 

drawing mode by pressing the [4] key. 

Make sure that the flap is still selected and select Edit-> Duplicate Special □ from 

the menu. In the second column of the Rotate row, enter the value 60 (the second 

column represents the rotation around the y axis). Enter a value of 5 in the 

Number of Copies field and press the Apply button. As a result, we get 5 new flaps 

in the appropriate places.  

For the end, all we have to do is mark all the objects together, make a new rocket group and save 

the scene by selecting from the File-> Save menu. 
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Example 2: Boat 

In the second case, we will upgrade the knowledge of the first case with other very useful functions 

and create a simple boat. 

Framework 
As with a rocket, in the case of a boat, you could first create a framework using a revolve tool. 

When setting the tool, you would set the curve to rotate only 180º. Instead, we will learn how to 

edit components. 

For the axis, we will use half of the cone, which is created by selecting Create-> NURBS 

Primitives-> Cone □ from the menu. We determine the following properties: 

• axis: z 

• end sweep angle: 180 (s tem bomo dobili samo polovico stožca) 

• radius: 1 

• height: 2 

• number of sections: 8 

• number of spans: 4 

• caps: bottom 

• select also Extra transform on Caps 

Then click Create. In the coordinate starting point, a cone 

will appear as shown in the picture on the right. 

If we look at the cone more closely, we see that it consists of several sections, in the horizontal 

direction of eight, and in the vertical direction of four, which corresponds to the settings of the 

creation tool. 

These settings have not been important to us so far, but they are very important in modeling, as 

each intersection of the two green lines in the image means one point that can be moved manually 

and thus change the entire object. We will see how this is used below. 

First, we will rework our cone a bit more. In the Channel Window, we will transform it by entering 

0.5 in the Scale X window, 0.75 in the Scale Y window and 1.5 in Scale Z. With this, we shrunk 

our boat, reduced its depth and lengthened it. 

 Now, however, we will manually change the cone to make it more like the hull of a boat. First, 

change the view to Side View. 

If shading is on, switch it off with the [4] key. Highlight an 

object and use the [F8] key to switch to Component Selection 

Mode. We now have a picture on the screen similar to the 

one in the picture on the right. 

To zoom in on an object so that it is completely in our view, 

it is achieved by highlighting it and then pressing the [F] or [A] key. 
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First we notice the purple dots. These points are control vertices (CV) and allow us to model an 

object accurately. 

 We will design the object by selecting points from 

right to left and moving them so that in the end we 

get something similar to the one shown in the picture 

on the right. 

When moving the control points, care must be taken to always select the points with the mouse by 

pressing and holding [LMB] to the left-above of the selected point and dragging to the right-bottom 

position, relative to the point. We will call this a marquee choice in the future. We have to choose 

points in this way because we have to take into account that we are looking at the object from the 

side, which means that there are parallel points on the opposite (invisible) side, which we also 

select and move in this way to ensure symmetry. 

 We will now change the view to the top and widen our boat a bit, giving it 

its final shape. As with editing from the page, here we select the points and 

move them so that we get an image similar to the image on the right. 

When finished, turn off component editing with the [F8] key. 

If we look at the boat in perspective, we see that the product is already quite 

realistic, but we must add to the object the thickness of the material with 

which it is made. 

We will first duplicate the already made frame, reduce it and fill the holes 

between the two objects, which will give us the feeling that the object is made 

of real material, such as iron or wood, and not of a very thin one, such as e.g. paper. 

Highlight our framework and select Edit-> Duplicate Special iz from the menu. If you remember 

the first example - rockets, you know that we have already used the duplicate function and that we 

have set some special properties for it. Maya has this property of remembering these settings until 

we change them. 

Therefore, within the Duplicate Special window, select 

Edit-> Reset Settings from the menu and then 

Duplicate. By doing so, we will be an object that is the 

same as our framework and that lies in the same place 

as our framework. The newly created object is also 

already automatically selected, so there is no need to 

select it again. 
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 We will now slightly reduce the new object by entering in the channel window: scale X - 0.8, scale 

Y - 0.8, scale Z - 0.9. After the duplication and reduction is complete, we get a picture similar to 

the picture on the right. 

We can observe that one side of the surfaces is dark and 

the other is gray. We need to know that Maya 

distinguishes between the inside and outside of surfaces. 

Therefore, the inner boat needs to be turned. To 

achieve this, highlight it and select Surfaces-> Reverse 

Directions from the menu. The result is the correctly 

oriented surfaces shown on the right. 

Loft 
Now all we have to do is connect the inside and outside of the boat. We will do this using the Loft 

function. To connect surfaces with the loft tool, we need to mark the edge curves of each surface. 

This is achieved by clicking on [RMB] on each shell and selecting isoparm. The mesh of both shells 

will thus turn blue. In this mode, you can select the edge curves you want to connect by clicking 

and the [Shift] key. When selected, they turn yellow. Then select Surfaces-> Loft from the menu. 

A new surface is created that connects the marked curves. If the surface is dark it is turned upside 

down and we have to turn it in the same way as we described above. Repeat this process for all 

missing surfaces. 

The image below shows the sequence of steps and then the final product. 
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Lection 03 

Maya - Modeling with polygons 
 

Povzetek 

1. Polygons 

2. Edges 

3. Vertices 

4. Extrude 

5. Create polygon 

6. Mesh smooth 

 

Unlike modeling with curves and surfaces, modeling with mesh geometry was developed for 

completely different purposes, as mesh geometry has limited accuracy in depicting curved surfaces. 

Of course, by adding details, we can increase the accuracy as we wish, but this is not the basic 

purpose of the technique. The basic components of a grid geometry are: vertices, edges, and faces, 

which are usually composed of polygons. 

What are polygons? 

Polygons are 2D primitives with three or more vertices. In 

fact, all polygons with more than three vertices are 

transformed into triangles before drawing, and only then are 

they drawn. The reason for this lies mainly in the design of 

graphis pipelines and due to the need for a uniform definition 

of objects.  
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Polygon geometry is still the predominant way of presenting 3D objects and is most prevalent 

mainly due to its use in 3D interactive computer graphics (e.g. in computer games). As a result, 

many different tools and accessories are available by designing 

such 3D geometry. In the following, we will look at how such 

geometry can be formed at the lower level - by moving 

individual vertices.  

Each triangle consists of the basic building blocks: (1) vertices, 

(2) edges, and (3) faces, which is also shown in the figure to 

the right. 

As we have already learned, Maya offers us a set of basic 

primitives for a starting point in 3D modeling (cube, cylinder, cone, …). Most of these building 

blocks can also be defined by polygons. When modeling using polygons, we take the nearest 

primitive as a starting point, which is then formed into the final desired shape. 

Why Polygons? 

As mentioned in the previous chapter, the main reason for their use is their high prevalence and 

consequent adaptation of both software and hardware. Last but not least, graphics cards are highly 

optimized just for drawing 3D geometry represented by polygons. 

A very positive feature is the compactness of the presentation. More complex 3D geometry can be 

designed from polygons by using a larger number of polygons in places where we want more detail, 

but where there is no such need, we can use a smaller number of polygons. 

They are also very convenient due to the fact that it is very easy to "glue" textures to polygons - 

images that represent a more detailed structure of objects and also determine their color and 

appearance. Over the years, many techniques have also developed that allow us to add additional 

virtual details to otherwise roughly defined 3D models (e.g., using bumps, offsets, normal 

mapping). There are still many advantages, but we will get to know only a small selection of them 

during the workshop. 

Creating polygon models 

To create polygon geometry, we need to start with one of the primitives available to us. The 

simplest is the primitive of the plane, represented by four vertices, 4 edges, and one surface. To 

create new polygons, we need to change such an initial geometry in edit mode, which is presented 

in the next section. 

As a starting primitive, it makes the most sense to choose the primitive that best represents the 

shape and properties of the desired final product. To make a face, we can start with a cube or a 

sphere (both are a good starting point), for elongated objects it is usually best to choose a cylinder 

or an elongated square, etc. 
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Example 1: Space ship 

We will learn the basics of modeling through modeling a simple space ship where we will take a 

cube as a basis. The cube basically consists of 6 faces, 12 edges and 8 nodes. 

Polygons 
While the rocket in the first lesson consisted of a multitude of curves and surfaces, we will use 

polygons made up of triangles to model the spaceship. The reason for this lies in the suitability of 

such a geometry for real-time rendering, as the hardware is strongly adapted to the processing of 

the geometry thus defined. 

Modeling 
To begin, we will create a new polygon cube Create -> Polygon 

Primitives -> Cube. If we have not changed the basic properties of the 

tool, a cube with an edge of 1 unit will appear in the center of the scene 

as shown in the image on the right. 

As we said in the introduction to the chapter, the cube has different 

components, which are visible in the pictures below: 

 

                           Faces                            Edges                        Vertices 

The basic form of network geometry can be transformed by arranging the components. But before 

we get into that, let’s show how we can model with grid geometry with some of the tools Maya 

offers. 

Extrue 
The most common tool used in polygon modeling is extrude. With this tool, a marked polygon or 

several polygons can be extracted from the model in the direction of its normal and thus create 

new faces in geometry. The Extraction Example tool is shown in the figure below. 
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We use both in component mode, which shows faces (right-click on an object and select face). 

Highlight one or more faces, then choose Edit Mesh -> Extrude from the menu (or use the shortcut 

[Ctrl + E] on a Mac [Cmd + E]). A special manipulator appears that allows us to pull out the face 

and move it relative to the original. It is most often pulled out in the direction of the blue 

minipulator. The face can also be enlarged / reduced at the same time. With this tool, we will 

continue to build the entire spaceship. 

Creation of space ship 
First, we change the cube into a square by scaling along one dimension. Then mark the edge faces 

of the square and pull them out and shrink slightly in the vertical direction. Then we pull out both 

new cheeks again, which we also shrink, and in addition we move back. You can use the shortcut 

[G] to reuse the same tool. 

 

Then do the extension of the central front cheek three times and reduce the back slightly in the 

devh directions. Mark the lychees with the nose pulled out, trigger the pull-out and reduce them 

slightly. With the next pull of both faces, we deepen them into the interior of the ship. This added 

openings for air intake during flight in the atmosphere. We also pull out the cockpit. 

 

We also add the tail wing, which is pulled out of the rear upper part of the torso, where the first 

pull-out first reduces the face, and the second pull-out pulls out the tail wing, which narrows at the 

top and moves back. In the last step, we add the drive opening of the main engine, which is made 

in the same way as the air intake openings. 

 

Our spaceship is extremely angular. To get a slightly more realistic look, it needs to be smoothed. 

To see a preview of the smoothed model, we can use the already known functionality of Maya, 



  

 

 

21 | FRI |  3D modeling using Autodesk Maya 

 

 

where we can switch between three levels of detailed display of the model with the keys [1], [2] and 

[3] as shown in the pictures below. Such an alien ship already looks more realistic, and we can 

make it in minutes. 

 

In doing so, we must be aware that we did not actually smooth the grid geometry, which we must 

also perform before the desired final rendering. 

Smooting 
Mesh Smooth is a process of more detailed division of 

the mesh geometry, which divides the individual face 

of our network into several faces, placing the 

intermediate nodes in such positions that the shape of 

the model is smoothed. In Maya, linear and 

exponential smoothing is available, and we can set a 

number of parameters for each. If you select Mesh -> 

Smooth □ v from the menu, you can choose between 

smoothing settings. By default, Maya smoothes with 

the exponential method with 3-fold cheek splitting. 

The final look for our spaceship is shown in the image 

to the right. 

Example 2: Squid 

Polygon modeling is also often used in modeling organic things, as the user has control over how 

the shapes will adapt to other things, where they will be more and where less detailed, and what 

similarities we will add. 

Manipulation of individual components 

As we have already shown in the case of curves and surfaces, even in the case of using a polygon 

grid, only individual components of geometry can be edited. Thus, scrolling, rotation, and scaling 

tools can be used to manipulate an individual or set of selected components in a single display 

mode. 
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Component display selection 
When you right-click on an object, a menu will appear with options to 

display the various components of the object. We are currently 

interested in: Vertex, Edge, Face, Vertex Face  and Multi (all three 

types of components). 

In this way, we can use selection tools to select those components of 

our object that we actually want to edit. 

Adding Edge Loop 
A very welcome modeling tool is also the Insert Edge Loop tool. The tool 

is available in the Mesh Tools-> Insert Edge Loop menu. This tool 

allows us to add a new loop of edges connected in one direction around 

the entire object (if possible) at the desired location on the existing edge, 

as shown in the example of the cube in the figure to the right. 
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Creating squitd 
We start making squid with a simple cone. In the menu, 

select Create -> Polygon Primitives -> Cylinder □ where 

we change the number of axis divisions (Axis divisions) to 

16 and change the axis along which we will create a cone 

to X and click the Create button. 

Switch to the detailed display mode with the [3] key. By adding new edge loops and evenly 

enlarging / reducing the entire edge loops in the top and side view, we finish the desired shape. 

   

                               Top view                                          Side view 

Add a few more loop loops and move the appropriate knots to form the squid head as well. 

 

We continue to make tentacles. Squids have 8 tentacles, of which 6 shorter and 2 longer. We will 

use a pull-out tool several times to make the tentacles. First, we select 6 faces for pulling out 

shorter tentacles, where we then reach the approximately desired result by pulling out, scaling and 

rotating. Repeat the process to make two longer tentacles. 

   

Let's work on longer tentacles a bit more to get a characteristically widened part at the end. By 

arranging the vertices at the front, we add the fins. With the extraction, add the characteristic 

jaws. 
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What’s left is to add eyes. There is still a lot of room to add details. 

 

Example 3: LEGO figure 

When making 3D models, we always use references. References can be photographs, pictures, 

sketches or even objects that we want to model. We can often help ourselves with images captured 

from specific views (e.g., from the front, from the side, from above, etc.). Such images can also be 

inserted into the scene itself as an aid to use. 

Using reference images in a scene 
Maya offers a very simple import of reference images into the scene itself, tied to a concrete view. 

We achieve this most elegantly if we have precisely aligned images from different views of the same 

dimensions and resolution. 
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In the view where we want to add a reference image, 

click on the button  in the viewport toolbar. A 

window for selecting a file opens, where we find the 

appropriate file with the image, select it and confirm 

the selection. In our scene, a surface appears aligned 

with the selected view, showing the selected image. 

In case we want to use several reference images in 

different views, we repeat the process for each view. 

If the reference images are not aligned or the same 

size, this can also be achieved in Maya by moving, 

enlarging / reducing the areas with the reference 

images. The figure on the right shows the use of two 

reference images (for side and front view). 

LEGO figure 
Based on the presented techniques, make a LEGO little man as shown in the pictures below. 
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Lection 04 

Maya – Advanced mesh modeling 
 

Overview 

13. Grouping geometry 

14. Editing geometry 

15. Deformers 

16. Live geometry 

 

Real-world objects often consist of simpler basic forms, or at least parts of objects take on more 

basic forms. Thus, we can also help ourselves in modeling by combining simpler shapes in the 

production of more complex shapes. Therefore we can use different tools to combine geometry. 

Tools for merging the geometry 

Bool operations 
You have probably already learned about Boolean operations in the basics of logic (union, 

intersection, difference) and as such they also appear in 3D modeling. In Maya, they are available 

in the Mesh->Booleans menu, where we find: union, difference, and intersection. In this way, two 

(or more shapes) can be combined as shown in the figure below: 

     

       Original objects                 Union            Box without spehere    Sphere without box         Intersection 
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With the difference opperator the result depends on which object we are subtracting from other 

objects (which depends on the order of selecting them). In doing so, we can observe that the 

density of the geometry grid summarizes the density of individual objects, which can occasionally 

cause headaches. Especially when we want to breathe a very specific shape of objects. 

Combining mesh geometry 
We can also combine mesh geometry without interfering with the 

composition itself. You can do this by using the combine tool. The tool is 

accessible from the Mesh -> Combine menu. As a result, we get one 

geometry that combines the grid representations of all the merged objects 

as shown in the figure to the right for the example above. In this way, we 

can then combine (or not) individual mesh primitives and connect them to 

each other. 

Separating the geometry 
If we have unconnected parts of the mesh in one geometry, it occasionally makes sense to separate 

or dismantle it into individual separate objects. This can be achieved by using the separate tool 

available in the Mesh -> Separate menu. The same can be achieved with the tool for detaching the 

part of geometry available in the menu Edit Mesh -> Detach. This tool separates the selected part 

of the geometry from the rest but does not separate it into another object. 

Editing geometry 

In the previous part, we learned about some basic tools for editing geometry, and here we will 

present some more tools that often come in handy. 

Chamfer 
Chamfer is a tool that cuts off a corner and replaces it 

with new corners moved along the connected edges. The 

operation is shown in the figure on the right. 

Merging vertices 
In Maya, we also have some tools for combining corners. The most commonly used: 

- merge, available in the Edit Mesh -> Merge menu, which combines selected vertices that 

are closer to the prescribed threshold. The threshold is set in the tool settings. 

- merge to center, available in the Edit Mesh -> Merge to Center menu, which merges the 

selected nodes into their center of gravity. 

- collapse, available in the Edit Mesh  -> Collapse menu, which collapses the marked edges or 

faces in the vertex. 
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Deformers 

With deformers, we can transform 3D geometry in accordance with mathematically undefined 

deformations. The deformers are available in the Deform -> Nonlinear menu and are: bend, flare, 

sine, squash, twist and wave. 

Deformers are merely modifications over objects and therefore do not change their functioning 

mesh geometry irreversibly. For this reason, it is also important that if we want to preserve their 

function, we pay attention to how we transform the geometry. 

Deliting geometry history 

If we are finally convinced that we no longer want to edit geometry properties based on initial 

attributes and / or deformers, it makes sense to erase the history of objects. This bakes the shape 

of the geometry and makes it independent of the initial paratmeters (e.g. number of sections in the 

cylinder, etc.). 

To do this, select the object and then select Edit -> Delete by Type -> History from the menu. 

Example 1: Teacup 

With the tools presented above, we can very easily create a cup from two cylinders as shown in the 

picture below: 

- one cylinder is used to make the main part, where by adding edge loops we increase the 

desired shape accuracy and by moving and scaling the corners we achieve the desired shape 

of the main part; 

- the second cylinder is used to make the handle. 

- Bend the cylinder, wipe its caps and bring it closer to the main part. 

- The cylinder is combined with the combine function. 

- With the chamfer function, add the required number of corners to connect the nets at both 

ends of the handles in the appropriate places. 

- With the merge to center function, we combine the corresponding pairs of nodes and thus 

connect both parts of the geometry. 
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Example 2: Hand 

With the same tools, we can also model more organic models, such as the arm. We mostly used the 

tools extrude, insert edge loop, combine, merge to center. We start with the box then make one 

finger, multiply it. Adjust each finger and attach all fingers to the palm. The process is shown in 

the figure below. 

    

Example 3: Goose 

We often use modeling to help us with approximate models, which represent the approximate 

shape of our final model. We can also create such an auxiliary framework by rendering basic 

primitives. 

In our case, we depicted the basic shape of the goose head with a few spheres to which we adjusted 

the size and stretched / shrunk them along each axis to fit the auxiliary sketches. The smaller the 

objects we use, the more accurate the framework can be established. 
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We further combined these spheres into one geometry using the combine tool. Then we erased the 

history of the newly created object and used it for a live geometry . 

In this mode, the mouse automatically sticks to the live object when creating a new geometry, so 

we can create new faces on its surface. We create new faces with the Mesh Tools -> Create 

Polygon tool. It is best to create quads and triangles. We must be careful to create them 

counterclockwise, otherwise the faces are turned inside out. 

We create faces next to each other. Once we have created the desired amount, we combine them 

with the combine tool, erase their history, and then connect them in the appropriate corners using 

the merge and merge to center tools. 

The final shape is obtained by adapting this grid in detail to the sketches and, if necessary, adding 

/ subtracting new nodes. 
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Lection 05 

Maya – Rendering 
 

Overview 

17. Materials 

18. Textures 

19. Lights 

20. Camera 

21. Rendering 

22. Post-processing 

 

The process of calculating an image showing our 3D scene is called rendering. In order to be able to 

calculate such an image, we have to assign materials to individual objects in our scene, place lights 

in the scene that will illuminate the objects, prepare a camera that will define the view of the 

scene, determine any special effects and finally trigger the rendering. 

Materials 

The appearance of objects in a scene depends most on what material the object is made of. In 

Maya, we have a collection of pre-prepared materials that we can use and adapt to our needs. 

Materials differ from each other in the way light is reflected. The most basic among them are: 

• Lambert material, used for matte surfaces (unpolished surfaces, chalk, etc.), 

• Blinn material, suitable for metal surfaces, and 

• Phong material, which is suitable for glass and polished plastic surfaces. 

In addition to the basic materials, there are many other materials available in Maya (with the 

Arnold renderer). 

Adding material to the scene 
We add material into the scene using the Hypershade window, which is opened in the menu by 

selecting Windows -> Rendering Editors -> Hypershade. Hypershade is a space where we work 

with materials and textures, lights, cameras and other elements that affect imaging. The 

appearance of the window is shown in the figure below and includes: list of materials and auxiliary 

structures (bottom left), list of already created materials (above), Properties of selected material / 
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auxiliary structure (right), and work surface for connecting materials and auxiliary structures 

(middle). 

 

We create new material by selecting the base from the left list. This creates a new material in the 

scene, which we will be able to assign to the objects, and at the same time this material and its 

composition are displayed in the central window. We adapt the material to the object in the scene 

by dragging it from the list above in the Hypershade window with the middle mouse button. 
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Adjusting material 
The material can be processed by changing the appropriate 

properties (color, transparency, etc.) in the right part of the 

Hypershade Attribure window. The number of material 

properties depends on the type of material selected and can vary 

from a few simple parameters (in the case of Lamberd type 

material) to a multitude of different parameters (in the case of 

materials included with the 

Arnold renderer), properties of 

Maya's material Lambert, and 

on the right Arnold's material 

aiStandardSurface. Arnold's 

material contains many preset 

settings that can be accessed via 

the Presets button. 

The most important common 

attributes that determine the properties of materials are: 

• Color – determines the base color of the material. Left-clicking on the color field opens a 

color selection window. With the slider, you can change the brightness of the selected color. 

• Transparency – determines the transparency of the material. Use the slider to change the 

intensity of transparency. By changing the color field, you can change the default white 

transparency (the material is transparent to all colors) to color transparency (the material 

is transparent to the selected color). 

• Ambient Color – determines the ambient color, which is present even without external 

lighting. 

• Incandescence – determines the color and intensity of the light emitted by the material (it 

does not illuminate other objects). 

• Diffuse – determines how strongly the material scatters light. 

• Specular Color – determines the color of the mirrored reflection.  

• Reflectivity – determines the reflectivity of the material. 

• Reflected color – determines the color of the reflection. 

Assigning material to the object 
If we want an object to have the properties of a material when it is rendered, we must assign it the 

desired material. To do this, click on the desired material in the Hypershade panel with the middle 

mouse button and drag it to the object. Alternatively, select an item (or items), then right-click in 

the hypershade panel to open the context menu and select the Assign Material to Selection option. 

The third option is to click on the object in the scene with [RMB] and select Assign Existing 

Material from the menu, then select the desired material. 
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Textures 

Textures add patterns to homogeneous base materials. Patterns can be based on color or some 

other attribute of the material (transparency ...). 

The process of making a simple texture is as follows: 

1. Add and adjust the material in the scene you want to add a texture to. 

2. In the left part of the Hypershade panel inside the Create section (in the Textures folder) 

with the middle mouse button click on the desired texture and drag it to the material on 

which you will paste the texture (the material is visible on the desktop in the right part of 

the Hypershade panel). When we drop the texture on the material, we have to determine 

which attribute of the material (color, transparency ...) will be associated with the texture. 

3. In the attribute editor, we process the texture according to our requirements. 

Lights 

Much like it is in the real world, the lights in Maya are needed to illuminate the scene. Maya 

knows some basic types of lights that we can use in our work. The basic types of lights are: 

• Ambient Light – radiates in two ways: some light radiates evenly in all directions from the 

position of the light in the room, and some light radiates in all directions from all 

directions. 

• Directional Light – strains evenly in one direction only, so that the rays are parallel to each 

other, as in the case of a very distant source of light (for example, sunlight). 

• Point Light – strain evenly in all directions from the position of the light in the room (for 

example, candle light). 

• Spot Light – strain evenly in limited directions (cone) from the position of the light in the 

room (for example, the headlight light). 

Adding lights into the scene 
The light is added to the scene with the help of Hypershade (similar to the materials included in 

the scene). By including a light in the scene, it is placed in the default place (center) in the room 

(and oriented in the default direction). The light must then be moved to the desired location and, 

in the case of a directional light, oriented in the desired direction. For this we use already known 

tools for movement and orientation or a light manipulator. 

Adjusting lights 
After we add a light to the scene, we adjust it according to our needs. We process the light by 

changing the corresponding attributes that define it (similar to the material) using the attribute 

editor. 

The most important common attributes that determine the properties of a light are: 

• Color – defines light color. 
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• Intensity – defines light intensity (it can also be negative => removing the light). 

Rendering 

Creating an image is the final stage in rendering. Based on the layout of the model, materials, 

textures, lights, cameras and special effects in the scene, an image or several images of the scene 

are created (calculated). Before we start creating the image, we can change the default settings of 

the parameters when creating the image (resolution, quality, ...). The image creation parameters 

are viewed and set in the Windows -> Render Settings window. It is used to review and set the 

parameters that determine the production (calculation) of the image. The window contains a large 

number of parameters, such as image name, image format, resolution, image quality and others, 

which can be changed and thus affect the calculation of the image. 

Some important parameters when calculating the image: 

• Image File Output -> Camera – specifies the active camera for the image. 

• Resolution -> Width – defines image width. 

• Resolution -> Height – defines image height. 

• Raytracing Quality -> Raytracing – include ray tracing calculation mode. 

You can create an image and view it in the window Windows -> Render View. 

Render View 
We use it to create and view created images. The image will be created according to the current 

rendering settings. The rendering process is started by clicking on . We can create only a part 

of the image by first selecting the part we are interested in with the mouse in the Render View 

window, and then clicking on to start the image creation process. Outside the part we marked, the 

previous image remains unchanged (useful for comparison). 

The default camera when making an image is the one that corresponds to the perspective view of 

the scene. 
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Lection 06 

Maya – Animation 
 

Overview 

23. Keyframes 

24. Animation curves 

25. Animation with deformers 

26. Animation with constraints 

 

Animation is a process in which we manipulate / transform / move objects and thus achieve the 

feeling that they are moving. Animation dates back to the 19th century and has been constantly 

evolving since then. 3D animation has its beginnings in the 1940s, and since the 1970s it has 

regularly appeared as an important part of the film industry. Since then, however, animation has 

appeared in a variety of environments for a variety of purposes. 

Basics 

Keyframes 
Animation using keyframes is done by placing / transforming the object into the desired position at 

the desired time points. During such positions, the animation frameworks can then create the 

animation themselves, which can then be further corrected using animation curves. 

The keyframe determines (fixes) the values of the selected attributes at some point in time. 

Attribute values at keyless intervals are calculated automatically. Place the key frame in the 

properties window on the right side of the screen or in the Animate -> Set Key menu (red bars are 

drawn on the timeline at the bottom of the screen for each set key point). The keyboard shortcut is 

the [S] key. 

You can set animation keyframes for almost any object attribute (not just position, rotation, and 

resizing). If you right-click on the name of a parameter (e.g., color material), you can select Set key 

in the menu to set the key frame for this parameter. 



  

 

 

37 | FRI |  3D modeling using Autodesk Maya 

 

 

Timeline 

At the bottom of Maya's window is a timeline that shows the length of the animation (in 

thumbnails) and where you are in the animations. By entering the value in the input window on 

the left and right under the time bar, you can extend or shorten the length of the animation. 

You can move to a specific animation thumbnail by clicking on the ribbon; if you press the bar 

with the left mouse button, all the animated parameters will be recalculated and set to the correct 

values, but if you press the bar with the middle button, the animated parameters will not get new 

values. 

 

 

Animation Curves 

Based on the set key frames, Maya calculates the animation curves for the animated attributes. 

These curves can be corrected in the Graph Editor (Window -> Animation Editors -> Graph 

Editor). Keyframes and tangents are selected with the left mouse button and moved with the 

middle mouse button. 

Example 1: Bouncing ball 

We will learn the basics of animation on the example 

of a bouncing ball. We will first animate the ball in 

place as shown in the sketch on the right. To achieve 

such an animation, it is necessary to use only basic 

transformation tools (displacement and scaling). 

We start right at the top, where we place the first key 

frame, then move on the timeline to where we want 

the ball to touch the ground. Perform the necessary transformations (move the ball to the base and 

partially flatten it). We add a key box. Let’s repeat the same for the lower bounce. In addition to 

flattening on impact, we can also add the stretch of the ball when accelerating. 
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In the second exercise, we add a shift 

along the horizontal axis, as indicated by 

the sketch to the right.  

When setting key frames, of course, we 

can fix them later and thus change the 

entire animation or just the part we are 

not happy with. We can also use a curve 

editor to correct certain properties of the 

animation, where we can set the 

properties of individual changes over 

time very precisely. 

Example  2: Swimming fish 

We will learn more advanced animation techniques with Maya on the example of a swimming fish. 

Our goal should be to create an animation in which a simple fish moves through the water with 

movements. It should be followed by a camera. 

Modeling fish 
Before we get acquainted with more advanced animation concepts, let's build a 3D model of a 

simple fish, which will serve as a basis for working with deformers and constraints. 

We will use a ball as a fish, the shape of which we will change. We will change the ball into a fish 

by directly transforming the control points, which are the basis of the ball (this method differs 

from changing the shape of the body by using deformers, which transform the body control points 

only indirectly). 

A fish in a horizontal position will be much easier to shape if the sphere has a polar axis in a 

horizontal position. Since the default orientation of this axis is vertical, we need to change the 

appropriate parameter to construct the sphere. Place the ball on the scene with 

menu selection Create -> Polygon Primitives -> Sphere □. The 

orientation of the polar axis of the sphere is changed by 

changing the Axis parameter. We set its value to X. We also 

make the design a little easier by increasing the number of 

control points. This is achieved by increasing the number of 

height and rotational distributions of the sphere. In our case, we 

increase them to "axis division = 10" and "height division = 

10". 

The sphere is transformed into a fish by direct transformation 

of the vertices as shown in the figure to the right. 
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Animation of swimming movements with deformer 
Realistic animation of the swimming movements of the fish with the direct transformation of the 

control points of the fish body would be very difficult to achieve. For this purpose, we prefer to use 

one of the deformers, which enable easy and complete changing of the shape of any objects. 

With deformers we can change the shape of any object, the structure of which is defined by control 

points. These are NURBS curves, NURBS plots, polygon plots and lattices. Maya contains several 

types of deformers. Some of them are, for example: 

• Lattice: allows free deformations based on the deformation network on the object; 

• Cluster: allows the transformation of control points with different impact; 

•  Nonlinear deformers: allow bending, twisting, wave, ... 

objects; 

Use of sinus deformer 
First we mark the object we want to deform (in our case it is a 

fish). Then we create a nonlinear sinusoidal deformer with the 

menu selection Deform -> Create Nonlinear -> Sine. By 

selecting the input node sine1 in the Channel Box window, we 

can interactively access the parameters of our deformer.  Since 

the parameter that determines the amplitude of the sine curve is 

equal to 0, we set it to one of 0 different values (for example, 

"Amplitude = 0.3"). 

Deformer animation 
The next step is to animate the deformer. This ensures that the curvature of the fish due to the 

influence of the sinus deformer will change over time. The parameter of the sinusoidal deformer, 

which in our case needs to be changed over time, is the Offset parameter. As a result, the impact of 

the deformer and therefore the shape of the fish will change. 

In the time window, we place ourselves on the thumbnail 0 (most likely we are already there). In 

the Attribute Editor window, set the value of the Offset = 0 and set a keyframe for this parameter. 

Then, in the time window, place one of the later frames (for example, frame 39), change the value 

of the parameter Offset = -2, and set the key frame for this parameter again. It makes sense that 

the absolute value of the Offset parameter in the second case is equal to the Wavelength parameter, 

as this way the curvature of the fish returns to the initial position. 
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At this point, our animation involves one full swing of the fish (frames 0 to 39) and the rest of the 

fish is motionless. The movement in the rest of the animation is created by periodically repeating 

the already defined animation of the Offset parameter. This can be achieved with the graph editor, 

which is opened with the menu selection Window -> Animation Editors -> Graph Editor. This 

shows us the animation curves for the parameters 

we animated. In our case, we see a curve that 

determines the value of the Offset parameter as a 

function of the frame number (i.e., as a function of 

time). 

Periodic repetition is achieved by selecting the 

desired curve and select Curves -> Post Infinity -> 

Cycle via the menu. This will repeat the change of 

the selected parameter in the animation 

indefinitely. 

Animation along the curve 
One of the last steps to realizing our idea is to animate the movement of a whole fish along a path 

here and there. We do this by creating a curve that represents the desired path and attaching the 

fish to that curve. The fish will then move along the curve from its beginning to its end during our 

animation. In this type of animation, we do not need to deal with the direct setting of key points. 

First, we create a curve that represents the path. This is done with the curve tool obtained with 

the Create EP Curve Tool menu selection. Subsequently, the curve can be further corrected by 

transforming the control points. 

The fish then needs to be pinned to the path curve. In fact, a sinus deformer also needs to be 

attached along with the fish in order to maintain the impact and periodically bend the fish. 

Therefore, it is best to group the fish and the deformer first (highlight the fish and the deformer 

and select Edit -> Group in the menu). Now attach the created group to the curve by first selecting 

the group then the curve and selecting Animate -> Paths -> Attach to Path in the menu. If we start 

the animation now, we notice that the whole fish moves along a defined path of movement and at 

the same time bends in accordance with the sinusoidal deformer. However, it is necessary to correct 

the orientation of the fish so that it is always directed with the head in the direction of the current 

movement. This can be done by changing the parameters Follow = on, Front Axis = Z, Up Axis = 

Y and Inverse Front = On with the attribute editor of the motionPath1 node. 

Camera tracking with restrictions 
Even tracking the camera of a moving fish can be greatly simplified. For this purpose, we can use 

constraints to ensure that the attributes of one object (for example, position) influence the 

attributes of another (for example, orientation) - position, orientation ... we limit with another 

object. 

Maya knows many kinds of limitations. These include, for example: 
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• Point Constraint, which limits the position of one object by the position of one or more 

others; 

• Aim Constraint, which limits the orientation of the object so that it is always directed 

towards others; 

• Orient Constraint, which limits the orientation of one object by the orientation of one or 

more others. 

We will follow the moving fish with a new camera, which we create with the menu selection Create 

-> Cameras -> Camera. This camera will not be static, but will follow the movement of the fish 

along its path with the direction of the body. We will apply the orientation limit. 

Orientation restriction is achieved by selecting a group with a fish and a deformer, and then a 

camera (the last object that will be restricted must be selected). Once we have such selected items, 

we create a constraint with the Constrain -> Aim menu selection. Finally, the orientation of the 

camera needs to be corrected. To do this, correct the Aim Vector parameter to (0,0, -1) in the node 

that represents the camera constraint (probably called camera1_aimConstraint1) with the 

attribute editor. 
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Lection 07 

Maya – Importing objects into 

Maya 
 

Maya supports a wide range of 3D formats that can be imported. The largest set of formats is 

available to us on Windows, elsewhere the set of formats is quite limited. 

You can use the IGES or STL format to download from the SolidWorks environment. Details for 

exporting IGES format models from the SolidWorks environment can be found in the original 

script for the RPO I object. 

If you do not need to open the exported models in Maya then turn off the Export 3D Curve 

features option when exporting to IGES format. 

3D models in the Maya era are represented either by mesh geometry or by surfaces. Working with 

them is the same as we have already met. 

 


